0

I have a Tablet with an SD Card in it and it doesn't show me the contents on it. On my PC I created a folder on the SD Card calling it Books, I put some epubs etc. into it and I got a few Epub/Ebook reader apps on my Tablet (it worked on my phone and I tried other Apps too) but when I tap on the Memory Card it shows me a bunch of folders that are Android related (I can provide a screenshot if needed) and my "Books" folder when I tap on it there is nothing in it and the path is /storage/emulated/0/Books

me, thinking: what does this mean. I already turned the power off, removed the sd card, turned it back on, turned it off, put the card back in, nothing. I formatted it too, nothing. When I go into My Files > SD card > Books I can see the content and the folders though the tablet asks if I wanna open them with either the Kindle application, a pdf reader or it tells me >no applications to perform this action

I just wanna be able to access my stuff from my sd card. When I go to Storage it shows me the internal storage and my sd card tapping on sd card only allows me to unmount it or format and I am confused and (slightly) annoyed since I've been trying to fix it for a while now.

  • I thought when I said "Marshmallow" it's obvious that it's 6.0.1 (are there other Marshmallow versions?) the Tablet is a Samsung SM-T550 Tablet. I obviously put the folder and the content back into the sd card AFTER formatting it. I'll post a screenshot in a second. – Nini Aug 3 '16 at 12:43
  • This is what it shows me when I tap on the sdcard with a reader for example 67.media.tumblr.com/c526f6eacd0a186ad798137d575dcdd1/… when I go to books it's just empty but when I'm My Files and I select the sd card it shows me only three folders (Andorid, Books the one I created including the files in it, and Lost.DIR whilst via app in shows me the things from the screenshot) – Nini Aug 3 '16 at 12:50
0

What you see, that it not your external sdcard, but your internal sdcard: /storage/emulated/0/ This is the storage your phone brings, when you have no external (removable) sdcard in it. Don't mix it up.

Under Android 6 this external sd is usually in a path like, e.g.: /storage/1234-ABCD/ where "1234-ABCD" is an arbitrary number of the individual removable sdcard. So try to open the external sdcard with your file explorer by going up two folder levels from /storage/emulated/0 and then you will find your data.

Maybe you try as file explorer the free app Total Commander which is very mighty and can help you find things.

By the way: under Marshmallow you need to allow explicitly each app, which is not a system app, to read the external sd-card. And writing it is another thing and even more difficult, as the app itself needs to bring the support for it (different from Android 5 though!). But with your internal file explorer (this is a system app) there should be no problems to read the external, removable sd-card, you just need to go up the path.

  • I assumed it was my external sd card since it shows me these folders when I tap on "sd card" I found my stuff now because it's not in the sd card folder where I assume it would be since that's my sd card but inside the system storage (?) folder. Kinda weird how they made it so difficult since most people, including me, would assume that it's the same as in Lollipop. Thanks for the help now I know where to look for my stuff! – Nini Aug 4 '16 at 14:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.