I have a Motorola Atrix 4G, with AT&T Carrier. Android 2.3.4

EDIT 11/6/2011: I don't know if this means anything, but I don' have an sdcard in it.

I have rooted it using this tutorial.

I installed Rom Manager and installed the Clockwork Recovery Image, with success (supposedly).

Here are where the problems occur. When I turn off the phone and turn it back on, while holding the volume down button, I get the big red M and scroll down to "Android Recovery" and select that. I then get "Failed to boot 2".

Ok, so I reboot and go back to my stock rom and try reinstalling the rom, and it down nothing to change the situation.

Next, I try running the fastboot software in the command window on my pc using the command "fastboot flash recovery recovery.img" (recovery.img is the clockwork mod). On my phone it says "Flashing Partition Recovery" then "Flashing MBR to device" and finally "Failed to process command flash:recovery error(0x180002)".

Any suggestions? I did google the problem, but the answers I have found didn't apply or didn't work.

Please help, Thanks.

  • Did you get the recovery.img through ROM Manager? How exactly did you install it the first time? Nov 6, 2011 at 6:07
  • The first time I did try, I used the ROM Manager. Since then I have tried reflashing the ROM with the fastboot flash and the ROM Manager again. Nov 6, 2011 at 12:45

2 Answers 2


Rooting the Atrix 4G does only that - gives you elevated privileges on stock OS. In order to be able to install a different recovery image and custom ROMs, the phone's bootloader must be unlocked first.

This is a fairly complicated process that carries the usual warnings and disclaimers of modifying phone software. It will most definitely void your warranty with AT&T (and possibly with Motorola as well,) so be very certain that your phone is either free of hardware defects, or out of warranty with your carrier before unlocking it.

See this thread on xda-developers forum for further details and installation instructions.

  • I just unlocked the bootloader last night, and it fixed the problem. I never thought to check it because I believed that the 2.3 update for the Atrix was supposed to unlock it or something. Anyways, I now have a rom on it and everything is well. Hopefully this answer will help someone else. Nov 7, 2011 at 19:01

I've taken a Motorola Atrix a couple of months before and all the threads I found have links to "sbf" (required to unlock) which have been removed from the net (I believe by Motorola itself) so basically I couldn't find any working "sbf" files to be compatible with firmware 2.3.4 nor a version of a program fastboot with inside a command called oem unlock available (all the versions I have tried are telling me that "unlock is not implemented")

I was not able to un-lock the Atrix for my girlfriend which is very depressing, because the actual ROM installed burns the battery in a very short space of time.

So, can anybody point me to a website that has a "sbf" file that works with Firmware 2.3.4 or a fastboot.exe which has enabled the function oem unlock

Thanks for help

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .