3

My Moto G4 Plus has the turbo Charging(30 min Charge 80%) feature. But when I connect to a Turbocharger, I get a display message on my lock screen as "Charging Slowly". On connecting a general charger Phone charges as usual in 3 hrs. I am curious to know, with only the given knowledge, how can I predict whether the issue is in Mobile Phone Hardware or Software or the specific Turbo Charger.

Charging Slowly Message on Home Screen Image

migrated from superuser.com Aug 4 '16 at 3:08

This question came from our site for computer enthusiasts and power users.

1
  • Moto phones are quite close to Nexus phones or pure android as commonly referred to, so the explanation below is valid

  • See Android phone "charging slowly": How to make it faster, for reasons on why charging slowly is displayed, in particular Andrew's excellent answer. To summarise, fast charging/ Turbo charging is achieved by increasing voltage or current or both, i.e. wattage ( being the product of current and voltage), as compared to conventional charging. Andrew's answer explains the values for which such notification appears ( Nexus phone on linked question uses a different type of which charging compared to your device, but that is a minor detail, since OS is flashing the notification based on wattage values and not on type of quick charging)

  • So, the most likely cause IMO, is that your Turbo charger is not working well or it is not receiving adequate voltage ( connect through a voltage stabiliser, avoiding extension boxes). You can verify otherwise by going to service centre and checking with the Turbo charger sample.

Do revert with your findings

Edit: I own Moto X Play and the charging cable is fused with the charger. If your charging cable can be detached from charger, try replacing with a good charging cable, to eliminate cable issue

1

I just hit the same issue. Check that you are using the microUSB cable that came with the Turbo Power charger. I had accidentally switched around my USB cables with a generic one, and noticed that my phone was charging slowly, even after reseating both cable connectors. When I replaced the generic cable with the original cable, it enabled TurboPower charging straight away.

Not sure if this is a case of the cheap cable having thinner power lines (i.e. higher resistance) or if the charger detects that this is the "right" cable. The original cable has a longer plastic lump on the microUSB end than the generic one, and it could be that there is a bit of circuitry in there that is needed for the phone to negotiate the faster charge with the charger, or that the phone checks whether the cable has a low enough resistance on the power lines to support higher current charging. If someone has access to the spec for Quick Charge 3.0 (a Qualcomm chipset feature which looks to be marketed as TurboPower by Motorola) feel free to revise this answer with the real deal.

FWIW, unless your mains connection is bad to the point of arcing, or you are in a severe brown-out, the power draw from the charger is not enough to see any problems from mains extension cords or power boards. These are the output specs from the product page for Motorola's TurboPower 15 wall charger:

Standard:   5V / 1.67A (8W)
TurboPower: 9V / 1.67A (15W)
TurboPower: 12V / 1.2A (15W)

So unless the voltage is very low due to some large load on the same power board, or a mains plug is making poor contact, it is unlikely that the charger will have problems drawing ~200mA from the mains.

Not the answer you're looking for? Browse other questions tagged or ask your own question.