2

I've literally tried everything it seems like. There was an another unanswered post on here asking something similar but obviously it didn't help since no one had answered.

RSA Fingerprint Dialog is not displaying - regardless of what I do

My phone used to display the RSA fingerprint dialog after selecting USB Debugging under developers settings. Now it doesn't. I'm very frustrated as I've only purchased this phone for the sole purpose of installing Kali nethunter on it.

I had the phone rooted before and installed the wrong rom for kali nethunter so I flashed the stock ROM back on to it and all is well and working except USB Debugging. I'm about to throw my phone away at this point... I've tried everything it seems:

Past, Frustrating Attempts

  • Try a different cable
  • Switch phone to PTP and MTP mode
  • Switch USB debugging on and off
  • Install and uninstall universal driver and google drivers
  • try different usb port
  • ADB kill-server / ADB start-server (Device still unauthorized under ADB Devices)
  • Install SDK manager and update ADB / Fastboot
  • Try a differnet OS (Windows 7, Windows 8.1, Windows 10, Kali Linux)
  • Factory Reset
  • Delete RSA Keys under 'C:.android'

All of these did not work.

My phone as it sits is unrooted (because I can't put it in USB Debugging mode) 6.0.1 marshmallow and TWRP installed as custom recovery.

  • Try this ? – beeshyams Aug 4 '16 at 4:43
  • Unfortunately yes, and it didn't work. That was the universal driver I had mentioned above. – Jake Wyatt Aug 4 '16 at 5:06
  • Is the issue that USB debugging is not working, or that you don't get the fingerprint dialog when you plug in a new computer? – mattm Aug 4 '16 at 13:02
  • I can't get the RSA fingerprint dialog when I plug it into the computer after checking USB debugging – Jake Wyatt Aug 5 '16 at 1:32
  • Is the ADB driver of your device correctly shown in the device manager? – Robert Sep 15 '16 at 13:15
1

You can reset the list of authorized devices by doing:

  • Developer Options
  • Under Debug Group select "Revoke USB Debug Authorization" (I'm translating from italian but should be something similar)
  • Unplug your phone and go to your launcher
  • Plug the cable to pc
  • Check when you connect the cable that Data transfer is enabled (from the notification that appears)

Hope this can fix the issue

  • I have the same problem as OP, and unfortunately after rooting my device no longer displays and "Revoke USB Debug Authorization" option... – hft Sep 22 '16 at 3:50
0

I have a very similar problem with the Galaxy Tab A, which I finally solved. I think this may solve your problem as well. The upshot is that I had to restart the "adbd" (adb daemon) on the device itself... I don't think it was particular to the Galaxy Tab A I was using.

In order to get adb working again I had to put the device into recovery mode (power down, then power up while holding power, up-volume, home button). I then went to the terminal application of the Team Win Recovery. In terminal I issues "stop adbd" then "start adbd". At this point the device now shows up on the local host PC when I run "adb devices" (it shows up as "recovery" rather than unauthorized). I can adb root/shell to the device now. This is really all I need to do. I expect this will solve my problem in non-recovery mode as well. Or, at this point I can push my PC pub key to the device and it should be fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.