0

I have a Galaxy SC-04F with a non-rooted, stock ROM that came with the phone, running Andoid 6.0.

I believe it's a common model, and I haven't done anything to it that I know of that makes it special or dysfunctional in any way.

But, Google Play says the standard Google apps Contacts and Phone are not compatible with my device.

Why would these apps be incompatible? Is there a way I can get them installed?

Contacts Phone

1

This is not the "standard contacts"app (AOSP contacts).

Google™ contacts and dialer apps only work with Nexus and Android One devices running (as far as I know they come pre installed) starting with marshmallow (Android 6).

  • I assume you installed a custom ROM to get lollipop? – xangua Aug 6 '16 at 19:14
  • Thank you for responding. My newer phone was recently updated to Android 6, but the problem still persists. I've updated my question. – Questioner Aug 26 '16 at 0:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.