3

For about a month and a half my Nexus 6P (running Android Marshmallow 6.0.1) has at random times shown a toast of "Check your connection and try again". This toast shows up no matter what app I am in, maybe two or three times a day, usually; so far today, however, my phone has given me this toast maybe 15 times.

When it shows up, I am usually actually connected to WiFi or Cellular (the issue has occurred on multiple wifi networks and multiple carriers), and loading a webpage immediately before/after it pops up invariably works. Here's what the toast looks like:

Check Your Connection And Try Again prompt 1 Check Your Connection And Try Again prompt 2

When it happens more The issue occurs more frequently (but not at all exclusively) when:

  • I'm downloading/updating an app from the Play Store
  • Uploading a photo from my device to Google Photos
  • I've just restarted my phone
  • I've just awakened my phone from sleep
  • My phone turns on after having been turned off with the Google App in the foreground (i.e. when the Google App is on the screen when the phone turns on)

Not actually a duplicate This question may appear to have been asked before, but those questions are about when the toast shows up in the Play Store app; I have nonetheless followed answers' instructions from those questions (instructions like clearing Play Store cache), but to no avail.

These toasts are annoying and I'd like to determine the source. Could it be an app? The Play Store? Google Photos? Or a system prompt?

What I've tried so far

  • Restarting phone
  • Switching WiFi networks, switching to Cellular
  • Clearing Play Store cache
  • Toggling Hotspot/Tethering on/off
  • Toggling Airplane Mode on/off

Phone Specs Nexus 6P, Android 6.0.1, not rooted, has Project Fi as carrier (used to be on AT&T, issue occurred then too)

Edit: One other solution to a similar question mentions the Freedom app, but I don't have that installed.

5
  • @beeshyams My phone time is already set automatically and besides that question isn't really my problem: I actually can download apps and open the play store does not give me that error.
    – owlswipe
    Aug 6, 2016 at 18:46
  • @beeshyams Thank you very much for that app idea, I had no clue it existed...and Toaster believes it's the NYTVR app (why would that be the one??). I'll try uninstalling it and seeing what happens.
    – owlswipe
    Aug 9, 2016 at 12:59
  • 1
    @beeshyams Problem solved. Thank you very much for your help.
    – owlswipe
    Aug 9, 2016 at 23:47
  • 1
    @beeshyams Accepted, sorry for delay :D.
    – owlswipe
    Aug 10, 2016 at 2:15
  • I've also had this problem with repeated toast messages, and interestingly, I also had the New York Times VR app installed. I've uninstalled it now, and I'll update later if this solves the problem. Oct 16, 2016 at 8:49

2 Answers 2

3
+50

Based on your assertion that your issue is not Play Store-related, I believe it is a malfunctioning app.

The Toaster app will help you track down the source of these "toast " notifications.

The app description reads:

Records every toast message including the sender package. May be helpful if you get messages and don't know which app sends it.

Update: As confirmed by OP, the Toaster app worked and the app responsible for the repeated notifications (as determined by Toaster) is NYTVR, the VR app of New York Times. Interestingly, there is one user review there which complains of the same problem faced by you!

Update 2: I tried downloading the NYTVR app to see if the same problem would arise (I am also on same OS, though I have a Moto X Play); however, I did not encounter any such notifications, which makes me think that this may not be purely OS-related, but rather a general bug in the NYTVR app that only occurs on certain devices.


If Toaster indicates that a certain app is sending the notification, make sure that app is updated and has settings set in a standard way. If you can't stop the notifications, contact the developer of the app or uninstall it.

Hope this helps!

1
  • 1
    Thank you very much for your help, I don't think I would have ever solved it alone...
    – owlswipe
    Aug 10, 2016 at 2:15
0

Had this issue on my nexus 6 too and tried all the things just like you
As far as i know this happens due to some data fetch that keeps running in the background which is unable to complete and following the android guidelines pops the toast message Check your connection and try again.
As far as i could find this happens due to a bad config during the update or some error during the data fetch.
What worked for me : Flash the stock images again using Fastboot
Now that you're not rooted and prefer using stock, I suggest that you flash the N Beta which has all the updated frameworks.
Good Luck!

1
  • Sorry, thank you very much for your answer but it wasn't the answer that helped me (see beeshyams's answer).
    – owlswipe
    Aug 10, 2016 at 0:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .