0

My LG G3 with Android 6.0 uses the built in Doze mode to save some battery.

At the first setup, I set applications to ignore Doze mode (like chat apps, Gmail, Viber etc.). I also set the "app" called Wifi to make my Wifi enabled while in Doze mode. They worked okay, I get my messages even if my phone is in Doze mode.

After 1 year of usage, when I unlock my phone, I can see that my phone is switching from mobile data to Wifi and my data package is being used up by the aforementioned disabled programs.

Why? And how can I make my phone to use Wifi permanently? What changed after 1 year?

  • It is not related to Doze AFAIK.. More like your WiFi is weak so it is switching over to data. Use this to measure WiFi strength when it happens and compare with known good WiFi WiFi Analyser – beeshyams Aug 6 '16 at 22:29
  • This is enabled under developer options> > mobile data always active – beeshyams Aug 6 '16 at 22:37
  • 1
    It seems like a bug in Doze itself - it's not expecting to do anything in that state, so needing to keep connected is making it forget how to connect. A workaround could be putting your phone in airplane mode, and then turning on the WiFi (yes, you can do that while in airplane mode) – Dan Brown Aug 6 '16 at 22:53
  • 1
    @DanB: good idea. Or as a workaround, use automation app (like Macrodroid) to disable data when WiFi connected. I use that trick to prevent data being on accidentally. There may be other apps on play store for this – beeshyams Aug 6 '16 at 23:21
  • 1
    @beeshyams Also a good idea :) – Dan Brown Aug 7 '16 at 8:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.