4

I started receiving the “Screen overlay detected” dialog when trying to change apps settings.

Tried to turn off all "draw over other apps" as it says here - "Screen overlay detected" dialog?, first without system and then with, but it still doesn't work.

Then, I restored apps to original settings and it just made a bigger mess, dialog continue appearing. Any way to go back to previous settings???

Thanks!

  • 1
    Check apps with accessibility privileges, in the Accessibility section of Settings, and turn them all off. – owlswipe Aug 8 '16 at 13:36
2

There are three places to check. Mine was caused by the Forest app under Acessibilty.

Non-system Apps

Settings -> Application Manager -> Apps with Overlay Permissions -> Apps with Permissions

System Apps

Same as above, but with Show System Apps turned on

Accessibility Apps

Settings -> Acessibility -> Scroll to the bottom. It lists app names. Just turn them all off for now.

1

PIE Controls turned out to be the problem for me.

Long story short, after trying every suggested thing I could find (even disabled permissions of some system apps, I will hopefully remember which ones and will be able to set it back...) I started thinking to myself, "what application could draw over the screen other than those on this list?" and realized that I had GravityBox installed through Xposed, and pie controls enabled! As soon as I disabled that (didn't have to turn off the entire module, just setting "enable pie control" to "never" was enough) I was able to finally set permissions!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.