4

I've got a strange issue going on with my adoptable storage setup. I have a SONY Xperia XA Ultra.

I initially got it working with a Sandisk 32GB Class 10 card. I adopted the entire card, and the Device storage went from "Total used of 16 GB" to "Total used of 48GB".

But then I had the bright idea to use one of my 64 GB cards, also Sandisk Class 10.

I repeated the process again, after reverting the 32GB back to portable of course, and adopted the entire 64GB card.

This time however only 16GB of the card was adopted, with the rest of the card basically lost. I couldn't see or access the rest of the card. Even with the Freespace app that part of the card just didn't exist.

So I reverted that and tried to adopt just 32GB, thinking maybe there is a limit to how much can be adopted. Same problem, only 16GB was adopted.

So I gave up, reverted that and went back to the 32GB card and adopted the whole card again. Only 16GB was adopted.

I tried 2 other cards a 64 & a 32, same problem.

And yes, I did migrate data and reboot each time. I even did a software repair before my last attempt.

Does anyone know how I can fix this?

  • This was sorted out by formatting the sd card in a PC, and not in the phone itself, then repeating the adoptable storage enabling process. – NeyLive Aug 9 '16 at 13:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.