0

Situation: to prevent Mi 2 Band's battery full vibration, which wakes me up; the notification bypasses Android's own Silent Mode
Secondary solution: use Do Not Disturb applicaiton of Playstore

Band is in the connection with the phone by Mi Fit of Playstore. My Pebble is connected to my phone by Gadgetbridge. Situation

  • In Mi Fit, DND active from 2100-0700
  • Android's Silent mode active but not effective
  • In Mi Fit, I find no setting about disabling the vibration of the band about the battery full status

My Settings > Notifications > App specific for Mi Fit

enter image description here

Phone: Samsung Galaxy S4, Oneplus 3
Phone OS: Cyanogenmod 13
Activity band: Xiaomi MI Band 2
Smart watch: Pebble Classic 1
Pebble firmware: 3.12.2 (newest 9.8.2016)
Pebble hardware: V3R3
Ticket at Gadgetbridge github about the issue: Can you Stop Vibrations of Mi 2 Band about Battery Full Status with Gadgetbridge?

  • So you're trying to stop Mi 2 app notifications from showing up on your Pebble, or what? – owlswipe Aug 11 '16 at 2:46
  • So you want your CyanogenMod phone to not vibrate when Mi Fit has a notification about full battery? – owlswipe Aug 11 '16 at 11:33
  • What about blocking all notifications from the Mi Fit app—to do that (though I'm sure you know how), just hold down on a notification from the Mi Fit app, hit the settings icon, and tap Block All. – owlswipe Aug 11 '16 at 21:06
  • Go to the Settings app on your phone, go to Apps, then find Mi Fit in the list. There, you'll see a Notifications row, click on that. Then tap the toggle for Block or Block All to on. That will block all Mi Fit notifications. – owlswipe Aug 12 '16 at 13:11
  • Ok, I understand now. I believe that as long as "Treat As Priority" is unchecked for Mi Fit in App Notification Settings, that Mi Fit cannot make notification noises. Go to the Settings app on your phone, go to Sound and Notification, go to App Notifications, and find Mi Fit in the list. In the Mi Fit notifications settings, uncheck Treat as priority. That will block sounds from Mi Fit notifications when your phone is on Priority DND (or Alarms Only, or Total Silence). – owlswipe Aug 15 '16 at 0:01
0

I resolved the problem by getting the second phone for my Mi Band 2 because I use Pebble at work, thus causing me much complications because no two internet gadget -support is not supported at the same time. This way, you can control the notifications of battery full -status stably.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.