4

Google Play Store alone accounts for 52% of my phone's battery use!

I would think Google Play Store would only run when downloading or updating apps, or when checking if apps need updated. Since last unplugging, I haven't manually run Google Play Store, nor have any apps been automatically updated.

Clicking through reveals that Google Play Store has been continuously requesting GPS. But I always have my GPS off in system settings.

I have all the sync settings off too. I don't want autosync.

So why is Google Play Store running uncommanded in the first place, and moreover, why is it using so much battery? How do I correct this?

Phone is LG G3 D855, Android version 4.4.2 KitKat. Rooted w/ xposed framework installed.

Screenshot of Battery Use view within Settings

Things I tried:

I pressed the "stop" button in the above screenshot, which force-stopped the Google Play Store. But then many system services started shutting down and prompting me with "not responding" dialogs, until I eventually pulled the battery and restarted the phone.

I used SystemCleanup to disable several autoruns (such as receivers) for Google Play Store, so that it won't be constantly called on to run. I also killed the task using SystemCleanup (which did not kill the system).

  • 2
    Turn off auto-updates, clear play store cache, check active threads (if you can't do any of those, look them up or comment below with @JohnRamos) – owlswipe Aug 11 '16 at 2:45
  • What is the version of Google Play? – beeshyams Aug 11 '16 at 9:12
  • @beeshyams Google Play version 6.8.24.F – TangoFoxtrot Aug 11 '16 at 11:42
  • @ElliottMurt Any change in consumption? Let me know. – owlswipe Aug 11 '16 at 11:50
  • @JohnRamos Not sure tbh because the previous solution I tried of using SystemCleanup to disable several autoruns, plus the below solution of hibernating the app, seems to have solved it completely. Today, the Google Play Store is nowhere in my battery use list! So the issue has been resolved. – TangoFoxtrot Aug 11 '16 at 21:06
1

Apart from turning off auto-updates plus clearing cache (as recommended by John), you could use Greenify to "hibernate" the app whenever it is not running in foreground. With Playstore being a system app, that would require the "donation package" of Greenify (in-app purchase). Side effect: even more battery saving when used on other apps as well (Greenify gives suggestions) and, if you're already on Marshmallow, by an advanced doze mode.

Greenify Greenify Greenify
Greenify in action / App Analyzer / Settings (source: Greenify; click images for larger variants)

A slightly different approach would be dealing with the auto-start events. AFAIR Playstore e.g. registered for changes in network connectivity, so it would always awake when you switch networks. Some references on how to deal with those can be found in the linked tag-wiki.

Not to forget: there are apps that cover several of the related topics (usually those "root toolboxes" or similar allrounders like SystemCleanup or ROM Toolbox):

SystemCleanup ROM Toolbox Pro
Disable receivers with SystemCleanup (left) or ROM Toolbox Pro (right); sources: GooglePlay 1 / 2, click images to enlarge

Another alternative would be ditching GApps completely, using a custom ROM without installing GApps and taking microG instead. To access app stores, you then can use F-Droid – and if you insist on accessing Playstore, there's BlankStore, a bare-bones Playstore client, for non-paid apps, and Raccoon on your PC for all apps (free and those you've bought). That's the way my devices are set up :)

  • What do you think about Francisco Franco's Naptime, which forces Doze to be always active (works only on Marshmallow, though)? – Death Mask Salesman Aug 11 '16 at 11:27
  • Thanks, @Izzy. Turning off the autoruns seems to have taken care of it, but I hibernated it with SystemCleanup for good measure. I used Greenify before but found it redundant with apps I already have. In this case it's the same end result anyway. I thought about the custom ROM too haha. – TangoFoxtrot Aug 11 '16 at 11:35
  • @DeathMaskSalesman Don't know, never tried (I have no MM device currently). // Elliot: Glad you've solved it. And yes, if you've got other apps covering that, you don't need Greenify for just that. And I see I forgot to mention autoruns (stupid me; that's what I've often used to keep apps from starting just because of network switching). Maybe I edit the answer and add that? – Izzy Aug 11 '16 at 11:55
  • 1
    Yupp. Most of the GApps have tons of receivers. One of the reasons Maps always runs in background if left "unattended" – though one might never ever have started it manually. A wag who suspects things behind that :) – Izzy Aug 12 '16 at 6:40
  • 1
    I'm using Locus Map for that. Bought it years ago :) // Btw: currently I'm extending my little tool Adebar to extract those "disabled components", so one can replay them on demand via ADB (e.g. transfer them to another device without needing a GUI). An example command, keeping Playstore from waking up on location change (why should it?): adb shell "pm disable com.android.vending/com.google.android.finsky.receivers.LocationProviderChangedReceiver" (did the same to com.google.android.finsky.receivers.BootCompletedReceiver ;) – Izzy Sep 14 '16 at 6:29
2

Please delete the Google Play data and login again. Update the GP if neccessary. Let this time autosync GP till all is synced and now you can disable the sync of GP only. I guess it won't use much anymore then.

  • I deleted cache and data and logged in again. Google Play does not appear in my sync settings. – TangoFoxtrot Aug 11 '16 at 11:51
0

I started having this issue recently with my Moto G 4G running stock Kit Kat 4.4. Play Store would keep GPS running.

I used App Settings an xposed module to revoke the fine positioning (GPS) permission from the Play Store (it can still use the coarse setting without draining the battery).

This has solved the issue for me.

  • Thanks for the input. Kindly link the module to improve quality of your answer, besides adding significant features that help in this case – beeshyams Sep 6 '16 at 8:50
0

I had the same problem on my LG G2 D802. It was solved by flashing the kdz from the same version i had (20H). I flashed twice, first a CSE flash, then a normal flash then a factory reset. Now the problem is gone even with the same version of the play store.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.