Unfortunately I seem to have a problem with my filesystem on my as internal storage formatted SD card. My problem is kind of related to this thread so I think it is worth mentioning here.

When I was restarting my device today I got the error that my SD card is corrupted. With a little bit of putting it in and out of the slot I eventually managed it to work again. Still the SD card is very slow and seems to have a corrupted file system. I managed to backup most of my data via adb pull but for some of the files I got an i/o error. I tried to run fsck as described in the other thread, but I cannot find any mount point of the SD card. I tried to umount every device in /dev/block/vold/ but it always gives me Invalid argument error.

Of course I cannot try to fix it outside of my running device, as it is encrypted.

Is an as internal storage SD card behaving differently? Where is the mount point for this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.