0

I'm trying to partition my SD card with a ~31gb FAT32 partition and a 1024mb ext3 partition for A2SD. I've tried making the partitions with CMW-Alpharev Recovery v2.5.1.8 and with gParted (on a bootable live USB stick) and neither works. Basically, whenever I try to create a second partition on the card, the second (or later) partition doesn't work anywhere. It's not recognized by my phone, Windows or gParted (even right after parttitioning). The first partition does work, though. So if the ext3 is first, the FAT32 doesn't work and vice versa.

I have no clue as to what could be causing this or how to fix it, any suggestions?

2
  • Have you tried partitioning via the Windows Disk Manager and formatting in Linux? Nov 11 '11 at 0:10
  • cant partition with windows disk manager, it will not let you partition an sdcard. You have to use either CMW or something like gparted. it has been a while since i partitioned mine and used A2SD, but I believe that ext3 needs to be first and fat needs to be last. Nov 11 '11 at 3:17