1

Soaked my phone (Moto G2, Marshmallow) and it died completely. I took out the micro SD card and unsuccessfully tried to mount it on my Debian system.

The SD card is recognized and I can see 2 partitions:

Device                                       Start                   End               Sectors                Size Type                 
/dev/mmcblk0p1                               2048                 34815                 32768                 16M unknown              
/dev/mmcblk0p2                               34816               7744478               7709663                3,7G unknown

However, I can't mount either one. I tried this way:

root@laptop:~# /bin/mount -t vfat /dev/mmcblk0p2 /mnt

Syslog contains the following:

[ 5880.536862] FAT-fs (mmcblk0p2): utf8 is not a recommended IO charset for FAT filesystems, filesystem will be case sensitive!  
[ 5880.537346] FAT-fs (mmcblk0p2): invalid media value (0x10)  
[ 5880.537349] FAT-fs (mmcblk0p2): Can't find a valid FAT filesystem

Q1: Is it possible that the sdcard is encrypted? If so, how could I verify this?
Q2: I have another Moto G2 with exactly the same model number (i.e. HW specs). Is there any way to restore the data on the card? (I know, this would defeat the purpose of encryption)...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.