0

I have rooted my phone and changed /system/etc/hosts file to block Facebook(just for test).

However, since I did it, I am not able to edit the hosts file again. As a result, I cannot visit Facebook from my phone! I've tried some hosts editors in Google Play but without a result. I've also tried to mount system rewriteable but it returns error ("Mount: Operation not permitted").

I've already rebooted the device, didn't help. I have no custom recovery installed. I've used Playstore apps that promised doing the remount, but mount -o remount,rw system has the same issue. The superuser app in place is the one from KingoRoot.

  • 1
    Could you clarify the error with a screenshot? – Death Mask Salesman Aug 18 '16 at 8:52
  • @Death_Mask_Salesman I think I have low reputation to post a picture.But it sais: Mount: Operation not permitted. – David_David Aug 18 '16 at 9:00
  • OK, integrated that with your question (and will cleanup comments now). Maybe you can edit it again and include the command you've used to remount the partition? It should be mount -o remount,rw system and be run as root. Some typo maybe? Or forgotten to run su first? – Izzy Aug 18 '16 at 12:28
  • @Izzy Your suggested command also returns the same error. I want to mention that I have used Google Play apps that promise to mount /system rw but nothing. I think something does not allow this. Maybe, the SuperUser app by KingoRoot is "is affraid " of being unistalled and secure that nothing can change /system permissions. – David_David Aug 18 '16 at 12:54
  • Uh-oh, Kingo again... No idea, but we've had a lot of trouble reports of that one here, yes. – Izzy Aug 18 '16 at 12:58
0

@David "I tried unrooting, but this cannot be done as it cannot access /system where KingoRoot apk is stored."

-Did you try to Unroot going on their "Superuser" app?

Superuser -> settings -> Remove Root.

That should do the job of uninstalling Superuser/Unrooting. It would still leave Kingo, but you can uninstall it from normal android settings -> Apps panel.

If you lost the root but their Superuser app is still installed, i would open kingo and re-root, then "Remove Root" after :-p

If the above fails and i could not remove it, i believe a factory hard-reset from the stock recovery options should fix it - have you done it ? you said "reboot" i dont know if thats what you meant.

(back up your data first, make sure you remember your credentials).

I would do one, and If it still did not solve the problem i would flash the SAME stock firmware i was using, then move my data back/reinstall apps.

And yes, like people say on the comments here - and also from personal experience - these "one click root" apps have the advantage of being really easy to use (maybe not the ones in chinese language lol) and work GOOD for lots of different brands/models... the disadvantage is these "half-rooted" cases (devices with Android 5+ ?) when the SU binary is not fully functional and will not work right for many apps that need SU permitions.

I had many similar mounting issues and some others with yet another chinese 1click app called "360 super root". UNfortunately, it was the only one that worked for my device so far. Kingo, king, iroot, wmroot all failed. This "360root" (aka permroot) was the only one to work, but its SU was buggy like yours seem. Fortunately now i managed to install a good root via custom recovery... root now works 100% for the stuff i need.

There IS a way of replacing Kingo's Supersu by a different/better SU app without losing the root Kingo did. There is a paid app that does this trick that is called "Super-SU-me" and also a manual/free way to do it, but dont ask me how :-/

By the way, what is your device brand/model and android version ?

  • @Piri_Droid thanks for your answer.First of all,I have tried removing root through the Kingo app,but it fails.What is more, I think factory reset will not remove Kingo app,as it is a system app,since it is located under /system. I've already re-rooted my phone with success,but unrooting still cant be done. Finally, I hate Huawei Ascend y530 running Android 4.3 – David_David Aug 31 '16 at 5:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.