0

For almost a week I'm trying to revive my Sony Android TV (KD-55X8005C) that bricked itself after a routine factory reset.

Long story short, here is how it looks like: video 1 & video 2. It seems to be a widespread glitch: reddit com/r/AndroidTV/comments/45sw8t/sony_android_tv_saferecovery_mode/ & community.sony com/t5/4K-Ultra-HD-TV/Stuck-with-initial-setup-screens-on-my-Sony-Bravia-4k-Android-TV/td-p/536150 and I would've sent it back like all others with great pleasure, only that I've bought it in the UK and then moved it to a different corner of the world and this is the reply I get from Sony Care: "In regards to your enquiry, please be advised that the UK warranty only applies in UK, and cannot be claimed over seas. Also, on this occasion and in view of your particular case, based on the supplied information, sadly we are unable to offer goodwill."

I've tried connecting via a USB2USB cable to adb fastboot it, but there's nothing under "List of devices attached" when I run the "./adb devices" command. I tried booting it in safe mode (volume down during startup) which worked, however the loop keeps on occurring. I tried reflashing the Sony firmware, but it didn't help - the old one is running no matter what, even after telling me "Software update complete".

Is there a way to sign out of the Google account? (I have already deleted the device from the Android device manager, I've also tried locking and resetting it, which didn't work - only the pointless alarm does.

I think I'm ready to set the damn thing on fire. Can someone please-please-please suggest how I can factory reset the Android OS, or at least log out of the damn Google account? It's connected to my wireless network at home, and the funny thing is that I can even play my Spotify music on it, so the OS is running behind.... can I connect and run adb commands somehow?

So the only two solutions in my mind are:

  1. Finding a way to make adb commands work (perhaps over the home network).
  2. Finding a secret combination of buttons to press to force Android to reset to factory settings in Safe Mode.

I would highly appreciate any input. Sorry for the rant.

0

Try this that works for some Philips Android TVs:

  1. Unplug the power cord from the power outlet.
  2. Press and hold arrow "Down" on the joypad at the back of the TV.
  3. Afterwards re-plug the TV to the power outlet, wait 10 seconds and enter "Android System Recovery" mode. Please note that on some models of Philips Android TV's joypad does not trigger "Android System Recovery"

Copied from: http://forum.xda-developers.com/android/help/guide-continuous-restart-bootloop-fix-t3344272

  • This doesn't work unfortunately :( – Adrian Sep 7 '16 at 9:21
0

Is your set stabilized on whatever screen? Do you hear the browsing on Home Screen sounds(beeps)? If yes then someone with exactly same Model can help to enable USB debbuging with a tricky way: Number of arrow or Enter pressing down or left or right until you reach the option to enable USB debbuging. This is a little bit silly but there is no other way. There is also a possibility, a shortcut when using external keyboard, to send you instantly on USB debbuging enable.

  • It's not exactly stabilized, it's more of a mini-crash after the "share location yes/no" screen where it sends me to the welcome screen again. It literally does this, so blindly navigating to enable USB debugging won't work. As for the external keyboard, do you happen to know the shortcut? – Adrian Sep 8 '16 at 12:15
  • Ok, so I've enabled USB debugging and connected via adb. I ran a "adb reboot-bootloader" command and the TV rebooted and it now shows a blank screen after the SONY logo. What does this mean? Is there a way I can "exit" this? – Adrian Oct 2 '16 at 17:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.