2

I have a Nexus 5 running Android 6.0.1, not rooted.

When I travel from one known WiFi network to another (possibly even am inactive at home), the phone does not automatically connect to WiFi. When I check the settings, WiFi is turned off. When I turn WiFi on, it connects happily. The WiFi signals are strong.

In the settings menu for this phone, I have gone to Settings -> WiFi -> (top right menu) -> Advanced -> "Keep WiFi on during sleep", and turned this on. It has been on for weeks, and still the phone turns WiFi off.

Question: How can I prevent Android turning WiFi off?

Due diligence: I have checked the forums, and nothing seems to solve this exact problem. (The setting above is mentioned as a solution. I wish it worked.) Also, few posts are recent.

3
  • Try Macrodroid. Triggers 1 WiFi state transition 2 WiFi SSID change Action WiFi configure connect to network or other choices Constraints none – beeshyams Aug 19 '16 at 7:51
  • Also see if enabling WiFi roaming scan always on in developer options makes a difference – beeshyams Aug 22 '16 at 6:38
  • Observe the behaviour and if WiFi roaming did the trick for you, let me know to post it as answer. You will need tag me as @beeshyams – beeshyams Aug 24 '16 at 12:21
1

Is there any battery saver/hibernator or such applications installed?

There is a possibility of these apps turning wifi off, while you are not accessing any data(ie, if there are no active foreground apps using the wifi).

The next case i'm not sure about is Android Marshmallow's Doze feature. I have seen people complaining about wifi being turned off, while doze kicks in.

As a solution, you can install any device automation tools like Macrodroid as mentioned in the comments above to tweak/bypass your problem.

5
  • Googling, it would seem Doze is the culprit. I'm pretty sure I haven't installed any battery saver / hibernator apps. I tried disabling Doze for Google Connectivity Services, but the problem persisted. Googling, it seems that Doze is way too aggressive, and activiates even when its documented functionality says it shouldn't. I'm going to hang out for a fix in 6.1. Macrodroid looks like it might be a solution, but I don't want to go there - yet. – Guy Smith Aug 21 '16 at 4:49
  • @GuySmith: you can try Macrodroid out. If it works , at least you know of a work around and then i can post it here to help others who may consider that – beeshyams Aug 21 '16 at 8:52
  • Also see if enabling WiFi roaming scan always on in developer options makes a difference – beeshyams Aug 22 '16 at 6:36
  • Thank you! Turning on the WiFi roaming in the Developer Options seems to have done the trick. For those who can't find Developer Options - they're hidden by default. Googling "access nexus 5 developer options" found me this: gottabemobile.com/2013/11/10/… – Guy Smith Aug 23 '16 at 21:41
  • Uh-oh. The WiFi Roaming made it better, but the WiFi setting is still turned off sometimes. :-( – Guy Smith Aug 23 '16 at 23:17
0

I've coded and uploaded an app specifically for this. It's called WiFi No Doze. It's pretty rough, but it seems to do the job.

https://play.google.com/store/apps/details?id=com.gingerdroids.apps.wifinodoze

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.