0

I upgraded my MOTO G 3rd Gen (XT1550) to Android M. After that I tried to root My Phone but unable to Root Android M. So I decided to Downgrade to Android L. But also unable to Downgrade.

3 Answers 3

1

Seeing the exchange of comments in other answer and the link provided, the problem is with SuperSu:

Version 2.62 ( from memory) is normal SuperSu

Version 2.76 is system less root, which provides root without modifying system partition. My device is rooted with this and I had the same problem.

Systemless root requires different treatment.

First thing to do is shut the device by adb shell reboot -p . Next is to boot into recovery, enter TWRP terminal and key ''echo SYSTEMLESS=true>>/data/.supersu'' without quotes ( I had read of this in this XDA post

After this reboot into recovery for custom recovery to replace stock. Else in some current devices the custom recovery is replaced by stock. See this for more Booting into twrp unsuccessful

2
  • +1: obviously you have much more hands-on experience with systemless stuff. I have CM on nearly all devices and system-mode SuperSU on others (yes I deliberately avoided systemless).
    – Andy Yan
    Commented Aug 21, 2016 at 13:53
  • @Andy Yan: Thanks. Not really. Not conversant at all with adb commands, so was referring to you for corrections. It was from hastily made notes when i got into the mess of systemless SU without knowing the complications ( accidentally deleted my earlier comment)
    – beeshyams
    Commented Aug 21, 2016 at 14:10
0

Instead of trying to downgrade, just get your phone rooted.

Phones like Moto G can be rooted as easily as unlocking the bootloader, flashing a custom recovery via fastboot and flashing SuperSU through it. If you're using one-click rooters then just give them up.

7
  • I tried flashing custom recovery and SuperSu but unable to Root. I tried it atleast 5-6 times.
    – Bhaskar
    Commented Aug 21, 2016 at 6:15
  • @beast_f5 What's the syndrome? Did the SuperSU app appear at all after flashing?
    – Andy Yan
    Commented Aug 21, 2016 at 6:43
  • After flashing supersu it goes to bootloop
    – Bhaskar
    Commented Aug 21, 2016 at 6:56
  • @beast_f5 Sounds like the SuperSU version is too low... Get 2.76 if you haven't.
    – Andy Yan
    Commented Aug 21, 2016 at 7:07
  • I tried with version 2.76. But my bad
    – Bhaskar
    Commented Aug 21, 2016 at 7:47
0

I got a solution for Downgrading MOTO G 3rd Gen (XT1550) Android M to Android L


1) Extract the folder *.zip

2) Enter in the Extracted folder.

3) If "fastboot" not installed

Then you can download it from here Download Fastboot

4) Test fastboot by typing: fastboot devices You should see:

<serial number> fastboot

5) You are now ready to flash the fastboot files

Fastboot Commands:

"Do commands manually, one at a time - checking that each one returns an [OKAY]."

NOTE: system.img_sparsechunks may differ in number + name - Always check contents of folder you're working with.

fastboot oem fb_mode_set

If you want to Downgrade from Android M to Android L the Don't flash gpt.bin

fastboot flash partition gpt.bin <---- Don't Do this Step

fastboot flash bootloader bootloader.img

fastboot flash logo logo.bin

fastboot flash boot boot.img

fastboot flash recovery recovery.img

fastboot flash system system.img_sparsechunk.0

fastboot flash system system.img_sparsechunk.1

fastboot flash system system.img_sparsechunk.2

fastboot flash system system.img_sparsechunk.3

fastboot flash system system.img_sparsechunk.4

fastboot flash modem NON-HLOS.bin

fastboot erase modemst1

fastboot erase modemst2

fastboot flash fsg fsg.mbn

fastboot erase cache

fastboot erase userdata

fastboot erase customize

fastboot erase clogo

fastboot oem fb_mode_clear

fastboot reboot

For Rooting MOTO G 3rd Gen (XT1550) Android M


1) Flash(Permanent) or Boot(Temporary) with TWRP

You can download TWRP from Here Download TWRP

  • Flashing TWRP

      fastboot flash recovery {TWRP File's Name with extension} 
    
  • Booting TWRP

      fastboot boot {TWRP File's Name with extension}
    

2) Restart the phone in recovery mode (If flashed) <---- Those who use booted using TWRP Skip this step

3) Using TWRP flash the SuperSU

You can download SuperSU from Here Download SuperSU

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .