I have a Samsung galaxy s6 edge+ and my wifi always turns itself off when the phone is locked and reconnects when unlocked. Now my wifi is set to always be on even during sleep, I have rebooted my phone done an virus scan and toured the settings and can't find nothing to fix this problem Android version 6.0.1 Anyone know what to do?

The doze documentation strongly suggests WiFi is turned off intentionally to save power.

If a user leaves a device unplugged and stationary for a period of time, with the screen off, the device enters Doze mode. In Doze mode, the system attempts to conserve battery by restricting apps' access to network and CPU-intensive services.

The following restrictions apply to your apps while in Doze:

  • Network access is suspended.
  • The system does not perform Wi-Fi scans.

If you want to keep your WiFi on, you could leave your phone plugged in overnight.

  • What if I'm out and family or friends are contacting me on Facebook messenger – James Bromley Aug 23 '16 at 12:57
  • @JamesBromley I don't see what that would have to do with WiFi. – mattm Aug 23 '16 at 13:04
  • I could be using a friends wifi and I don't take my charger everywhere – James Bromley Aug 23 '16 at 13:30
  • @James Bromley, Doze kicks in only when you left your phone on the table. Or if there is no contact with your phone for a few minutes. But the priority notifications are opted out from hibernating by doze. – Abhishek K Aug 24 '16 at 8:03

I had the same issue. I tried: resting Wifi timers, turning off energy optimizers, still Wifi constantly turned off. Following worked: https://appuals.com/why-does-my-android-wifi-keep-turning-off/

Method 5: Clearing Data of Settings

On Android, the Settings app holds all kinds of data from paired Bluetooth devices to changes made when adding a new Wi-Fi connection. Some users have reported that clearing the data of the Settings app made their issue disappear. Let’s try it:

Go to Settings > App Manager.
Change the app filter to include ALL apps, including system apps.
Scroll down and look for the Settings app.
Tap on it and start by clearing the cache.
Tap on Clear Data and restart your phone.
Reinsert your Wi-Fi password and see if the issue repeats.

Update your phone to next major version of Android. The latest for you phone is Android 7.0

I actually had this same problem on my old S6 Edge. It kept turning off the WiFi and it never stays on for more than 5 seconds. It just started out of the blue. I then updated to Android 7.0 and this fixed the problem for me.

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.