4

I have been a fan of Google Voice typing for a long time. I use it for 2 languages, English and Italian.

On the Android Keyboard I can switch the language of the spell-checker by pressing the "World" icon. Until a few months ago, that would also change the language of Google Voice typing, i.e. when I pressed the microphone icon and start speaking, Google Voice typing would interpret my words in the language I had selected in the keyboard.

Right now instead, Google Voice typing got "smarter" and doesn't care about my keyboard setting, it just automatically detects the language I'm speaking. Of course it gets it wrong most of the time, and that is very frustrating, in particular because when I speak Italian (my mothertongue) it often thinks I am speaking English instead.

So, does anybody know if I can disable this automatic language detection and revert to the old behavior? Or do you have any suggestion on a workaround?

  • have you found a solution? That problem drives me nuts too. My temporary fix is to switch between my usual keyboard (Gboard or Swiftkeys) and Speechkeys, which is not great but does let you select the input language for Google Voice Typing. It's not an ideal keyboard as when you switch it shows you a long list of languages instead of favorites, so I'm looking for alternatives. Would love to hear any updates on your part! – zx81 Feb 13 at 12:33
  • Not really, the only workaround is to speak very slowly and split the words very clearly... – Andrea Zonca Feb 13 at 16:21
  • Ha, so you still have the issue. For switching languages, SpeechKeys works but is really ugly and gives you a list with all the languages of the world every time you switch, instead of your installed ones... It would be great to have the feature within the Gboard or SwiftKey keyboards. One way to get their attention is to post reviews in the Play Store. Also just posted a feature request on the SwiftKey forum, in case anyone can be bothered to comment and vote. – zx81 Feb 14 at 11:28
1

Unfortunately at the moment it is impossible to disable automatic language detection and force the speech to text to interpret spoken words with the language set manually in the keyboard.

0

Go to Settings app of your phone and choose Google Voice typing option. Inside this you have an option to choose your Default Primary Language, as shown in below screen shot:

enter image description here

You can chose your Default (Italian) by Press + Hold the language name. Click SAVE and Google voice typing should pick your Updated default Primary Language irrespective of your Keyboard Settings.

  • Thanks! I already have this setup as you explain. Unfortunately it still detects language automatically. – Andrea Zonca Aug 30 '16 at 14:04
0

This is a two-step process:

  • Settings > Language & input > Google Keyboard > Languages. Here disable English (disable Use System language if enabled) & only enable Italian.

  • Also in your Google Voice Typing option, set your Default Primary language as Italian.

Now Voice Typing will not pick up English words even if you wanted it to.

  • I want to be able to do Voice Typing both in Italian and English, I just want to choose manually instead of automatically ( which is usually wrong) – Andrea Zonca Sep 1 '16 at 14:53
  • Sure definitely. Choose your language as mentioned in the post. – rakshakhegde Sep 3 '16 at 11:24

protected by Community Oct 20 '16 at 1:39

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.