1

I have a Galaxy S4 and have only had it since October 20, 2015, and I was on my phone when it suddenly restarted itself without asking me. When it came back on the error message that is my title appeared. I can't go on Google Play Store anymore. I had wanted to update an app cause it won't let me play unless I do so. The message reappears very often, almost every 5 secs. I've tried uninstalling updates, deleting cache and data on both Play Services and Play Store, as well as force stopping them, going into recovery mode and clearing cache partition, and resetting app preferences. I really wish I don't have to reset back to factory settings because I don't know how to backup my phone to anything and really don't want to lose anything on my phone.

Update: I have tried getting a rid of cache on Google Framework and installing an updated version of Google Play Services.

P.S. Is there someone I can get in contact with if this doesn't stop? Preferably an email, but if not a store. Thanks!!

  • 1
    adb logcat -b crash, to see what happened exactly. – Yai0Phah Aug 24 '16 at 4:14
  • 1
  • The link @RahulGopi posted is a good find (a case similar to yours), and includes two steps you didn't yet try: clearing the cache (NOT DATA!!!) of the Google Services Framework and manually installing the latest update for the playstore app. At least the former is worth a try – for the latter, make sure you pick a trustworthy source ;) – Izzy Aug 24 '16 at 6:55
0

Reading your question, I can assume you are a little bit experienced with android. Now, here is the answer: Your Google play store/services will keep popping that error message because they are not up to date. On top of that, many apps might(and ideally should) have stopped working and would show you the error that appname has stopped working. The reason is same - Google play services are not up to date.

Solution: When you want to update an app normally, you go to play store, but here it is not possible. You have to flash G-apps manually. I would suggest you download the zip file from here: Open Gapps

G-apps are nothing but few mandatory Google apps. This would not reset anything or you would not loose any data at all. Factory reset is not required.

Background: Updated version of android (say Marshmallow) would not work with the google play services of its predecessor(play services of Lollipop). This is exactly what happened in my case a couple of days back. I flashed new custom ROM with old Gapp package(of Lollipop version), because I was so lazy to download new Gapp package :) . Hence I was facing that irritating error message every 5 seconds.

Hope you have found the answer useful!

0

In my case, it's because I disabled Google Play Service and other Google apps that I find "unnecessary". You need to update Google Play Services in order to get rid of that error.

If you also disable Play Store, you most likely won't be able to access it, but if you can, you can just update Google Play Services from there. If you can't get into Play Store, you need to search for the latest Google Play Services APK on Google.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.