0

My Nexus 10 stopped booting. It shows an open padlock on startup and the Google text in the middle. So I figured my son unlocked the bootloader somehow after creatively following instructions he found on youtube. I then tried to proceed to installing a fresh rom. Saw that CM has the "Manta" roms. I have handy the main rom: cm-13.0-20160820-SNAPSHOT-ZNH5YAO0J6-manta.zip. I found two recovery roms: twrp-2.8.7.0-manta.img and cm-13.0-20160820-SNAPSHOT-ZNH5YAO0J6-manta-recovery.img. I'm able to get fastboot to see my device, after doing the vol up+down / power thing. But then the command fastboot -w flash recovery cm-13.0-20160820-SNAPSHOT-ZNH5YAO0J6-manta-recovery.img never completes.

Creating filesystem with parameters:
    Size: 29783752704
    Block size: 4096
    Blocks per group: 32768
    Inodes per group: 8192
    Inode size: 256
    Journal blocks: 32768
    Label: 
    Blocks: 7271424
    Block groups: 222
    Reserved block group size: 1024
Created filesystem with 11/1818624 inodes and 158176/7271424 blocks
Creating filesystem with parameters:
    Size: 553648128
    Block size: 4096
    Blocks per group: 32768
    Inodes per group: 6768
    Inode size: 256
    Journal blocks: 2112
    Label: 
    Blocks: 135168
    Block groups: 5
    Reserved block group size: 39
Created filesystem with 11/33840 inodes and 4363/135168 blocks
sending 'recovery' (7860 KB)...
OKAY [  0.932s]
writing 'recovery'...

That never finishes. The tablet shows, aside from the laying down Android picture and the info, a blue line: "FASTBOOT STATUS - flash:recovery". It never gets past this. I tried this with both the recovery img files I found. Anyone have any idea why my Nexus 10 can't seem to complete this fastboot recovery installation? I'm doing this using Xubuntu 15.04 btw, and I don't have Windows handy. I seriously hope it isn't a Linux limitation thing. adb has always worked great. Fastboot sees and interacts with the device, so, that part should be good I hope.

  • My Nexus 10 tablet remains a brick. Andy below tried to help, but we could not make any conclusions other than the tablet having possibly broken flash memory. ps. I don't understand the aggressive down voting that I'm getting here. So, some people don't "like" me posing this question. Yet, it's not a problem that anyone has an obvious answer for. – Mike Sep 10 '16 at 18:16
  • Trying a different USB cable may help – Jan S Sep 19 '16 at 12:36
  • I tried 3 different cables. I tried from multiple USB ports, usb 2 and usb 3 ports. I tried from two different Linux boxes. I tried using tool from two different android sdk versions, and also a standalone mini archive of tools that provide just adb and fastboot. I also tried from within a windows virtual machine. The result is the same every time no matter what. At the point where it has to write to the nand memory, it just hangs. It's unlocked. Another interesting observation is that trying to lock it, it claims the command is successful, but then it remains in unlocked state. – Mike Sep 19 '16 at 18:59
  • So, it seems the device has become a total read-only device now... Its too bad, because it was otherwise a fine tablet. I'm balking having to shell out money to replace it. – Mike Sep 19 '16 at 19:00
0

Don't use CM recovery. Get latest TWRP here. Report back if this doesn't work either.

Also, you're supposed to get other partitions up-to-date to ensure compatibility with new ROMs. If you're not sure, flash a factory image.

  • Andy, I appreciate the help. I have learned things here and there about Android flashing, starting way back with an MK808B, but it remains still somewhat sketchy in my mind. I've tried flashing twrp-3.0.2-0-manta.img using fastboot. It hangs at the same point again: "writing 'recovery'", and the tablet shows the blue label with "FASTBOOT STATUS - flash:recovery" at that point. Re partitioning. How can I get a summary of the partition sizes, what should it changed to, and how does on change it. I take it it's different than using fdisk. – Mike Aug 30 '16 at 1:40
  • I tried to download stock rom mantaray-lmy49j. Untarred it. executed flash-all.sh. Erasing boot, recovery, system, userdata, bootloader, went "OKAY". But then it got stuck at "writing 'bootloader'" which doesn't complete. Table's blue status bar shows "FASTBOOT STATUS - flash:bootloader". I have the feeling that I now bricked it. I mean, bootloader was erased, and couldn't write a new one... – Mike Aug 30 '16 at 2:21
  • It looks like any write operation won't get through. Please do grab a Windows PC and test if possible - I had ADB- and MTP- related problems on my laptop's Ubuntu installation too, and had to resort to Windows when tinkering with Android. If that won't do then your N10 likely has a borked NAND prior to this. – Andy Yan Aug 30 '16 at 3:19
  • I just fired up my Windows 7 VirtualBox VM, installed the Google USB drivers, got fastboot.exe to recognize the tablet. Then, did fastboot flash recovery \tmp\recovery.img (I renamed the file based on a forum message), and again, same thing: sending 'recovery' (9296 KB)... / OKAY [ 1.125s] / writing 'recovery'... and it never completes, hangs. Tablet shows that blue line "FASTBOOT STATUS - flash:recovery". It seems indeed nothing can write to the device. How can a tablet just break on NAND just like that?? – Mike Aug 30 '16 at 4:22
  • @Mike It's a 2012 device, and Sammy's flash are known prone to bricking bugs historically (though I don't know if N10 is affected). – Andy Yan Aug 30 '16 at 4:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.