0

I know that this question was asked for several times, but I tried almost every solution that was suggested and Android Studio still doesn't see my device.
My configuiration:

  • Windows 7 Professional 64-bit
  • ASUS ZenFone Go ZC451TG. Andrdoid ver. 5.1


What I have already tried:

  1. check usb3 or usb2. Lollipop doesn't work with usb3
  2. check the orginal cabel
  3. try reboot Windows, ASUS
  4. try drivers from Google, ASUS
  5. Install drivers from ASUS, only 2014 works on my device. Last Update from 2015 doesnt' work because of 64-bit system.
  6. Turn on developer's mode on device
  7. try MTP and PTP modes
  8. Try PC Link standard utility form ASUS. It doesn't work properly on my PC

On this screen you can see how Windows detected my phone. enter image description here
Is it right? I worry that Winodws see my ASUS as memory device not AVD.
Can you suggest any ideas how to fix it?
Thanks in advance.

  • The picture you have only meant that the device is detected as a media device (for MTP storage mode), which should work even without the drivers. – Andy Yan Aug 30 '16 at 11:51
  • Yeah, I hope so. But unfortunately it doesn't work – Averin Maxim Aug 30 '16 at 11:54
  • Have you turned on USB debugging? It's not the same as turning on the developer options. The setting for USB debugging is about one screen down the page of developer options. – Dan Hulme Aug 30 '16 at 12:02
  • @DanHulme yeah, I check it several times, and it works – Averin Maxim Aug 30 '16 at 12:05
  • repeat of above. Are you sure 'USB debugging' is on?Do you see the device when you issue 'adb devices' in command window. – Iftekhar Aug 30 '16 at 14:41
1

Don't have enough reputation to comment but are you certain you've installed the USB driver? If not, start at: https://developer.android.com/studio/run/win-usb.html

Then go to this link b/c you may need an OEM driver: https://developer.android.com/studio/run/oem-usb.html#InstallingDriver

Your above point 8. Try PC Link... doesn't work properly on my PC may be the place to start. Make sure you can connect, transfer files, etc. before moving on the the Android Studio drivers though. I use Motorola phones & always had to make sure their connection worked first.

  • I can transfer files on my ASUS as on usual USB flash drive – Averin Maxim Aug 30 '16 at 19:31
  • @Averin then next step is to make sure Google USB driver is installed as per first link. Then try 2nd link for OEM driver & pay close attention to the path (sdk\extras\google\usb_driver). Does your phone show in the device manager when connected? Also, I usually run MTP mode with Android Studio. – JC23 Aug 30 '16 at 20:32
  • Yes. it is installed. Now it is the first time, when my ASUS recognized as ADB, but still it has a warning triangle and Error: Code 10. – Averin Maxim Aug 31 '16 at 6:05
0

The problem was solved. After detecting my phone as videoadapter not as a storage error:code 10 appeared, but then I switch to PTP mode on my ASUS and finally Android Studio saw my device

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.