I recently bought a Nook Color. My intentions from day 1 was to install CyanogenMod7 on the device to get a full Android experience. That process worked just fine, and the device is now running CM7. I am running CM7 installed directly on the device, not from an sdcard.

I access my devices a lot via command line using adb, but with the nook color, I am unable to get adb to see the device.

I have Windows 7 64-bit, I used the USB drivers, and "fix script" from here and USB Debugging is enabled. If I mount the device to windows I am able to access the sdcard on the device. But no matter what I do, I cannot get adb to see the device.

  • Crazy obvious question, but did you restart the PC and/or adb daemon (adb kill-server and adb start-server)? – Chahk Nov 14 '11 at 15:54
  • Added Windows tag - this question isn't device-specific. – Broam Nov 14 '11 at 18:30

I finally tracked down a fix after some file searching...

The "adb over usb" fix creates a file in %USERPROFILE%\.Android\adb_usb.ini with the "vendor id" of 0x2080 in it.

I have a .android folder in my root of my sdk directory c:\android-sdk\.android\, and in there is also the adb_usb.ini. I added the 0x2080 to that file, then restarted adb and I can now see the device via USB->adb.


Try removing the existing drivers and starting the Windows driver installation from scratch.

  1. Connect the NC to your machine via USB.
  2. In Win7 go to Start, right-click Computer and select Management, and then Device Manager.
  3. Locate the Nook Color device that should be either under "ADB Interface," "USB Mass Storage Device," or "Other Devices" section, right-click it and select the Uninstall option. When presented with a confirmation, choose to remove drivers as well.
  4. Disconnect and re-connect the NC. This should bring up the New Hardware Installation wizard, but fail to install the drivers.
  5. Install the drivers you downloaded from the XDA thread.
  6. After installation completed, restart the ADB daemon via Command Prompt by using the adb kill-server followed by adb start-server commands (or simply reboot the PC.)

You should now be able to access the Nook Color via ADB.

  • 1
    those are the exact steps I already took, and yes, i started the pc, adb and the nook color. still not showing up in adb devices. – Ryan Conrad Nov 14 '11 at 16:11
  • 1
    Here's another source for the drivers and patching/installation instructions. If I recall correctly, I had to use this method to get my NC recognized. nookdevs.com/NookColor_USB_ADB – Chahk Nov 14 '11 at 17:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.