I've been trying for a few weeks to root my android device. I'm running a ZTE Whirl 2 (Z667G) and none of the 25 one-click root programs have worked on it. I've given up on that path.

So I started researching rooting with ADB but I've had so many different problems there. Here are all the different methods I've tried, and their error messages:

psneuter: 'Failed to set prot mask: inappropriate ioctl for device'

zergRush: does nothing at all

adb root: 'adbd cannot run as root in production builds'

adb remount: 'remount failed: operation not permitted'

mount -o remount,rw /system: 'mount: operation not permitted'

All I'm trying to do here is remove the useless system apps from /system/app. I'd like to root my phone but the main reason I'm doing so is to get that crap off my device. Thanks in advance to anyone who can help me!

  • Have you already tried KingRoot? it worked on all of my Devices (Alcatel,Samsung) kingroot.net
    – ShulkerHD
    Dec 4, 2016 at 19:31
  • Try kingoapp.I rooted all the phones using this. you can root it using adb also Try it kingoapp.com
    – Pritom
    Dec 4, 2016 at 20:14
  • FYI, The OP is running Android 4.3.3 because that's what all ZTE Z667G's run.
    – MD XF
    Dec 6, 2016 at 17:20
  • @ShulkerHD Doesn't work for the said device.
    – MD XF
    Dec 8, 2016 at 19:34
  • 2
    this is a partial root, but might work: reddit.com/r/perktv/comments/35w5mn/…
    – user186920
    Dec 9, 2016 at 14:17

2 Answers 2


PSNeuter and ZergRush are too old-school (2.3.x-era), no wonder why they won't work.

This is a very unpopular phone so it doesn't have a custom recovery either. If the one-clickers (usually comes with the latest exploits) won't work then you're out of luck for now.


While this will not allow you to run traditional root apps (ZTE has write-protected all relevant system partitions making it extremely difficult, if not impossible, to install a su binary), it does give you full, persistent root access over ADB.

What does this mean? While you can't run apps like Beermoney Assist (unless the developer rewrites it to funnel commands through ADB somehow), you can set up network ADB access and clear the data via ADB from your computer via task scheduler, for example.

This is specifically for the Whirl 2 and will not work with the Zinger, which is not vulnerable to the same exploits. As with any device modification tool, use this at your own risk.

The instructions are on XDA Developers and aren't going anywhere soon :)

Discussions Thread: http://forum.xda-developers.com/general/general/zte-zinger-z667t-10-android-gsm-t2936545/

Partial Rooting Tool: http://forum.xda-developers.com/showpost.php?p=60725232&postcount=447

This may not work for you but it is the best I could find. Good luck !!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .