1

I am wondering if there is any way to run *# codes on android using adb command

I have tried this:

**service call phone 2 s16 "*#06#"**

tried with % instead of # as well.

Any help will be much appreciated.

3

Here's the command to type in ADB mode to show IMEI info:

adb shell am start -n com.android.settings/com.android.settings.deviceinfo.ImeiInformation

For Terminal Emulator from device:

am start -n com.android.settings/com.android.settings.deviceinfo.ImeiInformation 
  • but i still need to know how I can run that command from adb, as i want to run another code for testing phone, which is *#0*# – Tarinder Sep 1 '16 at 14:47
  • Try: am start -n com.android.settings/com.android.settings.TestingSettings – Gokul NC Sep 1 '16 at 14:52
  • gives me this error, adb shell ell am start -n com.android.settings/com.android.settings.TestingSettings < tent { cmp=com.android.se/system/bin/sh: adb: not found ttings/.TestingSettings } arting: Intent { cmp=com.android.settings/.TestingSettings } < /system/bin/sh: Starting:: not found 0) requires com.sec.testingsettings.permission.KEYSTRING < droid.os.P/system/bin/sh: syntax error: '(' unexpected at android.os.Parcel.readException(Parcel.java:1620) <el.java:16 – Tarinder Sep 1 '16 at 15:48
  • Download Activity Launcher. Select Settings app in that app and note down which Activity corresponds to the Testing Activity and launch it using am start – Gokul NC Sep 1 '16 at 15:52
  • sorry i didnt understand, Can you explain a bit more please. I have downloaded the app "Activity Laucher" but dont understand what to do next. Many thanks – Tarinder Sep 2 '16 at 9:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.