3

This is an SM GT900F.

I tried to install TWRP per these instructions. However, when issuing
heimdall flash --RECOVERY recovery.img --no-reboot
I got this (some clutter removed):

Initialising connection...
Detecting device...
Claiming interface...
Setting up interface...
Initialising protocol...
Protocol initialisation successful.
Beginning session...

Downloading device's PIT file...
ERROR: Failed to send request to end PIT file transfer!
ERROR: Failed to download PIT file!
Ending session...
ERROR: Failed to send end session packet!
Releasing device interface...

The phone was then stuck with a tiny blue dot on the left, which I suppose is the start of the blue progress bar mentioned here. It wouldn't react to anything anymore.

Fortunately, after removing the batteries, it boots just fine into the stock ROM. (Phew.) I have repeated this twice since, but this is consistent.

Does anyone have any idea how I should proceed?

2
  • Do you have access to a Windows-powered computer?
    – Grimoire
    Sep 2, 2016 at 21:58
  • @DeathMaskSalesman: Nothing else.
    – sbi
    Sep 3, 2016 at 0:36

3 Answers 3

2

TLDR: It works with Heimdall 1.4.2 (which at least in my case i had to compile myself from source code).

Unfortunatley i don't have the reputation i need to comment. But in my humble opinion... sbi you have not answered or solved your own question(at least you didn't solve the specific problem you have been dealing with)... and should unmark your answer as the right answer.... You say it yourself.. It is just an assumption (unless you have testet it).

I had the same problem using ubuntu 16.04 and the heimdall from the ubuntu-repository(i.e. heimdall version 1.4.1). I had exactly the same output, as you postet in your question...

Searching the web, i found this this manual, describing that this error occurs in version 1.4.1 and is fixed in version 1.4.2 of heimdall. That tutorial shows you how to download the source code of heimdall(version 1.4.2) from https://gitlab.com/BenjaminDobell/Heimdall and compile it yourself.

Following that tutorial, it worked for me smoothley.

1
  • I understand where you come from. However, while I don't know what the exact problem was back then (likely several problems), I distinctly remember running into the lack of admin rights several times, so I posted that as an answer. Of course, it might well be that, by some twist of fate, when I tried again I was using 1.4.2 rather than 1.4.1, and that solved the problem. If so, however, then that was a singular problem with a certain version that has since been fixed, so that newbies are very unlikely to run into it.
    – sbi
    Jan 20, 2020 at 18:47
1

Try Odin instead of heimdall, and use corresponding .tar format recoveries. No more hassle of Heimdall command line.

7
  • Unfortunately, this doesn't seem to work either. Working from this, I never get to the part 5 where it says "you get a sign in Odin (ID:COM section) and "Added" in message box". I must be doing something wrong, still. :(
    – sbi
    Sep 3, 2016 at 12:41
  • @sbi Looks like a different problem from the original, fortunately. Driver installed? Device booted into Download Mode? Did the OS prompt anything about installing drivers (it should if you're doing it the first time)?
    – Andy Yan
    Sep 3, 2016 at 12:48
  • Yeah, everything goes to plan until I start either heimdall or Odin and it doesn't. :( I had rebooted my machine just to be sure. (I rarely ever do that.) I even stooped so low as to install Kies, since this is recommended at some sites where they have instructions, but to no avail. I am not sure how to proceed now.
    – sbi
    Sep 3, 2016 at 13:03
  • @sbi I'm at a loss too... All I can suggest is to try a different port or PC altogether.
    – Andy Yan
    Sep 3, 2016 at 13:18
  • @sbi Try to reboot the Samsung in download mode first. Then, plug it to the computer and start Odin.
    – Grimoire
    Sep 3, 2016 at 13:25
0

I know this is coming late, but since my question is still getting votes, I might just as well answer it:

I have done many S3 and S5 in the last few years, and it seems the key to this was to do it with admin rights. I'm using Odin nowadays to do this, so I right-click it and start it as administrator. This might be the same for heimdall (you'd have to start a console with admin rights, of course), but I haven't tried that in a long time.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .