1

I have rooted my Sony Xperia M2 Dual (D2302) using KingRoot and it currently has Sony stock firmware (android 5.1.1, build: 18.6.A.0.182) with locked bootloader. I have checked the root availability using Rootchecker app from play store. To link the apps to micro SD card Link2SD app has been installed from play store. A 16 GB class 10 micro SD card has been used to provide the second partition. The partitions I have tried (using Minitool) are-

  • 8 GB FAT32 + 6.8 GB EXT2
  • 8 GB FAT32 + 6.8 GB EXT4
  • 8 GB FAT32 + 6.8 GB FAT32

In each and every case when Link2SD is launched, selecting ext2/ext4/fat32 shows "Mount script cannot be created. mount: Operation not permitted" error. I have rebooted the phone several times, checked root permission again and also tried to "su" from terminal and there were no error. In the Link2SD storage info the second partition is shown as "not mounted" partition. Why this error is being occurred? What should be the solution to this problem? Is it possible to solve the problem by running custom mount script?

  • i have the same problem, i have installed an app, then i make it as a system app and now i cant make it a user app again, shows me that error message: "mount: operation no permitted" did you fix it? – Yeison Fernando Vega Gómez Jul 20 '17 at 0:57
  • Yeah, I have fixed it. The KingRoot didn't actually root the phone with all of the r/w permissions at /boot and /system. So, I have unrooted the phone and rooted again with EagleRoot and got full access to the /system and /boot directory. So that, Link2SD didn't show this error anymore. To root using Eagleroot you can follow this link (forum.xda-developers.com/xperia-m2/general/…) – Mansib Jul 21 '17 at 17:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.