I recently started getting the following notification:

Low on space: Phone storage space is getting low.

When I click on the notification, it takes me to the "All" applications screen listing how much space each application takes, and at the bottom it shows:

Internal storage: 296MB used, 452MB free

Why is it complaining about low space when only 1/3 of the internal storage has been used?

Edit: This is on an HTC Incredible both before and after the upgrade from Froyo to Gingerbread.

Edit 2: Looks like it's not just me:





Edit 3: Called Verizon about the issue (expecting to get the standard "do a factory reset"), but instead got escalated to Tier 2. The Tier 2 person looked up the issue in their system and said it was a known bug and that HTC is requesting all people with the bug not do a factory reset but instead call their tech support at 866-449-8358. I called them and they told me a fix (via OTA update) has been released and will upgrade the Android version to 4.08.605.2 (I currently have 4.06.605.3). Last night my phone did try to do another OTA update, but after restarting it complained that it could not install it due to low memory. The HTC rep told me to remove applications from the phone until the low memory warning went away, then dial the following number to force the phone to check for system updates (it normally only does it once a week or so):


I did this and still haven't received notification of a system update, but hopefully within a week I'll get pushed the new version...

Edit 4: Called again (both HTC and Verizon) to see if there was any other way to force the update again, but they told me all I could do is try a factory reset. A lot of people are running into this, more references:





  • I am seeing this only after the upgrade to Gingerbread
    – smp7d
    Commented Nov 16, 2011 at 16:16
  • @smp7d: I had low space warnings before the update, but they may have been legitimate. After the update it got much worse to the point where I almost can't use the phone without something force closing or complaining about memory.
    – jrdioko
    Commented Nov 16, 2011 at 17:21
  • I tried what Verizon instructed you to do in Edit 3 (still waiting). Not a couple of minutes later I had the low space warning again. I'm amazed that there are not more people complaining on this site.
    – smp7d
    Commented Nov 16, 2011 at 21:44
  • @smp7d: Same here, I called again and they said to wait 24 hours and if I don't see anything call back. They definitely know about it (you can just say "the Incredible low memory bug"). Yeah confused why it's not more prevalent, even one of my coworkers ran into the same thing.
    – jrdioko
    Commented Nov 16, 2011 at 23:22
  • The problem is back. Posted another question.
    – jrdioko
    Commented Apr 2, 2012 at 19:26

2 Answers 2


Got these instructions from http://gadgetian.com/27505/htc-droid-incredible-vzw-gingerbread-update-4-08-605-2-dwonload/?replytocom=18668#respond It worked for me. My update is installing as we speak. :)

"Here is the fix for those of you still stuck in limbo between the Gingerbread Rollout and the patch, and have not gotten another OTA announcement again.

Clear borked upload from cache

1.Boot into recovery •Press and hold Power, Choose “Restart” option •When screen turns off, press and hold Volume Down and Power

2.When the white HBOOT screen appears, use the volume button to move down to “RECOVERY.”

3.Press the Power button to select “RECOVERY.”

4.When the triangle and exclamation appears, hold the Volume Up and Power button at the same time.

5.Using the volume button, scroll down to “Wipe cache partition” and select it.

6.Select “Reboot system now”

You can now wait for the update to show up again or you can follow steps below to force an update check:

Manually change the date on your phone to one year ago. This will trigger an automatic check in with the update servers and you will get the appropriate update.

  1. Menu > Settings > Date and Time

  2. Un-check Automatic to prevent the date and time from automatically updating

  3. Change the date to one year ago (under Set Date)

  4. Uncheck Background data from settings menu under Accounts & Sync (don’t really know if it makes a difference, but I did it anyway)

  5. Go back to the main settings and select About Phone > Check For Update and follow the prompts (I had to do this about three or four times.) It went MUCH smoother over Wi-Fi

Caution…when clicking install and reboot, it will stay at the Droid Eye screen after reboot for a while (~5 mins), but eventually, it did get installed.

Read more: http://gadgetian.com/27505/htc-droid-incredible-vzw-gingerbread-update-4-08-605-2-dwonload/#ixzz1gUZiGs1H"

  • 1
    Thanks for elaborating on the links I posted earlier. I should clarify that when it says "one year from today," it means a year ago (in the past), not a year in the future. That confused me at first.
    – jrdioko
    Commented Dec 14, 2011 at 17:55
  • Excellent! The reformat-cache thing unstuck my creaky old HTC Incredible and it's now happily updating. Thanks!
    – cbare
    Commented Feb 26, 2013 at 4:19

Alright, finally got it after spending a while digging through Android forums.

This thread explains how to clear the /cache partition. After doing that, this thread explains several ways to get the update to trigger again. The one that worked for me was to temporarily set the date one year in the past.

  • so are you all set now? i may try this tonight
    – smp7d
    Commented Nov 21, 2011 at 16:35
  • @smp7d: Yep, the new update installed and I haven't seen any low space warnings since.
    – jrdioko
    Commented Nov 21, 2011 at 17:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .