0

I have an Asus Zenfone running Android 6.0.1. and a Bluetooth headset (Philips SHQ6500) that I had paired but accidentally selected the forget option. Now it's impossible to re-connect it because the phone cannot see the headset at all. I restarted both devices and did a hard reset for network settings but the problem persists. Googling didn't help so I'm stuck at the moment.

  • Forgetting a BT device shouldn't make it constantly denied. Did you cross-check both devices' BT to see if they work with other devices? – SarpSTA Sep 4 '16 at 1:37
  • I think it's the headset's fault. Check the manual - for example, on my Tracer Mobile BT, the headphones will only accept new connections if the power button was pressed for more than few seconds when starting the headphones – pzmarzly Sep 4 '16 at 2:05
  • Try this app, may help – beeshyams Sep 4 '16 at 2:56
  • Headset won't be discoverable if it thinks it is already paired. Need to somehow reset the headset. Having said that, android BT stack has so many bugs its unreal. A third party BT scan app is probably a good thing to try. – Mark Ch Sep 4 '16 at 9:58
  • 1
    @SusanaGraça. Great! But what worked? LOL. – Tom Russell Feb 26 at 5:40
0

I faced a similar situation. Following steps worked for me. Some of the steps might be redudent.

1) restart your phone

2) reset network settings (Setting> back and restore )

3) change the phone bluetooth name. (I assume this is the solution)

4) set the bluetooth device in pairing mode (long press the power key).

And it worked for me. Probably, executing only step 3 would be sufficient.

I hope I saved your precious 30 minutes:)

protected by Community Jun 29 '18 at 17:29

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.