0

I've used my Nexus to test CM and other ROMs before; but now with 6.0.1, I simply can't get it to work with USB neither under Windows or Linux.

On Lubuntu it says:

[  36.853678] usb 3-1: new full-speed USB device number 6 using xhci_hcd 
[  36.965697] usb 3-1: device descriptor read/64, error -71
[  37.181684] usb 3-1: device descriptor read/64, error -71
[  37.941764] usb 3-1: Device not responding to setup address.

On Windows 10, it is Unknown USB Device (Device Descriptor Request Failed).

I've tried 3 cables and 3 other devices (Windows Phone, Android), everything else is working. I've opened up and cleaned the USB port, nothing happened. The device charges successfully.

I have installed all Google Drivers and whatnot, adb and fastboot doesn't see the device - not in normal mode, not in recovery mode.

If I connect the device, it will not show the USB connection options on Android.

Any suggestions?

0

it turned out it was a cable issue. still amazing - all other usb2 devices worked correctly, but the nexus 7. 4th cable to the rescue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.