0

XPeria Z3C on Marshmallow.

Starting some weeks ago, I don't receive notification unless I turn on the screen. While that was business as usual for games and other "come check X", it started to do that to received SMS too.

The result is that, when I think about ulocking my phone, I see SMS coming, sometimes dated more than half a hour ago, usually in the range of 5~20min ago. I randomly get notified, never on time, sometimes in the range of 2~5min ago, more often 10~20min ago.

I think it is related to some power saving options that reduced (way too much) the fetching of new message when in idle mode, but the only one I found is the new "Battery Saver", which is turned off.

Relevant informations:

  • Rebooting didn't help.
  • Removing the battery is sadly not a option on this phone.
  • SMS notification is on Priority
  • Battery Saver is off
  • Default SMS app.
0

That might happen because Android 6 has a function called Doze. Try going into Settings - Battery and look for Battery Optimization. Add there the apps that you want to make sure they sync / ignore battery optimization and see if it still happens.

http://www.androidcentral.com/inside-marshmallow-what-doze-how-do-i-use-it-and-what-does-it-do

  • OP has mentioned default SMS app. That should not be affected by Doze – beeshyams Sep 7 '16 at 14:13
  • 1
    @beeshyams: The Sony default SMS app is not the stock Google messaging app, and it seems it got "optimized". I ve removed the "optimization", will report if it changed something. – DrakaSAN Sep 7 '16 at 14:15
  • 1
    Not really. It happened to me on my S5, that's why i said it might be an option. It was fixed after an update, but still, it happened. – Mike N. Sep 7 '16 at 14:16
  • 1
    I confirm it is due to Google "optimization". – DrakaSAN Sep 9 '16 at 14:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.