2

I have a nexus 6 with TWRP and a stock ROM (6.0.0). I decided to update via OTA. However, for this I need to flash the recovery.img as stated in this anwser. Following the instructions there I've done the following steps (i'm usign linux):

  1. Downloaded the factory image from here for Nexus 6 (6.0.0)
  2. extracted the recovery.img and moved it to a separate folder
  3. booted into bootloader and connected with my workstation.

the device was detected correctly:

ola@thinkstation:~$ fastboot devices
ZX1G427VQJ  fastboot
ola@thinkstation:~$
  1. I flashed the recovery.img and rebooted

everything went fine:

ola@thinkstation:~$ fastboot devices
ZX1G427VQJ  fastboot
ola@thinkstation:~$ fastboot flash recovery /home/ola/temp/android/recovery.img 
target reported max download size of 536870912 bytes
sending 'recovery' (8915 KB)...
OKAY [  0.351s]
writing 'recovery'...
OKAY [  0.298s]
finished. total time: 0.648s
nicolas@thinkstation:~$ fastboot reboot
rebooting...

finished. total time: 0.001s
ola@thinkstation:~$ 

I then rebooted and tried to download the 6.0.1 via OTA. The download was successful. However, after restarting and the beginning of installing I get an Android icon and the message "Error". That's it. I then tried to boot in to bootloader and do a recovery mode where I get an error "No Command". So I reflushed the recovery.img leading to the same result. Normal booting works perfectly fine. Whats causing the error?

  • Did you do any modification to the system (root, Xposed, everything counts)? – Andy Yan Sep 10 '16 at 11:24
  • @AndyYan it is rooted. – user8 Sep 10 '16 at 13:30
  • My answer should be able to help you to understand the reason behind the error. Also, give us the exact error message. – Firelord Sep 10 '16 at 13:48
  • @user8 System mode or systemless? System mode root will kill OTAs. – Andy Yan Sep 10 '16 at 14:17
  • @AndyYan I have superSu v2.78 systemless if I'm not completely wrong. How else can I check? – user8 Sep 10 '16 at 15:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.