1

I am trying to root SAMSUNG Galaxy XCover 3 (SM-G389F) with Android 6.0.1. I successfully flash the latest TWRP (twrp-3.0.2-0-xcover3ltexx.img.tar official site) with Odin 3.12. See Odin Log In Odin I intentionally disabled Auto Reboot, so that I try to boot into TWRP recovery in the first phone boot by holding down (Home + Volume UP + Power key). Instead of booting into recovery the phone gets stuck on SAMSUNG Galaxy screen as shown in video link. After normal reboot my phone boots up as normal but this action puts back stock recovery.

To solve the problem I tried all available TWRP's, tried to factory reseat and clear phone cash several times before flashing recovery image, tried to use various Odin versions (3.07, 3.10, 3.12).

What else can I try?

Thanks for suggestions.

  • Something went wrong with the flashing of TWRP. Try again, perhaps through the app. – Dan Brown Sep 12 '16 at 9:19
  • Rooting through the app is not possible. My conclusion is that at this point in time it is not possible to root SM-G389F because current TWRP for Samsung Galaxy Xcover3 [link] dl.twrp.me/xcover3ltexx does not support SM-G389F. This is also indicated in the name mismatch on TWRP download site (xcover3ltexx) whereas my SM-G389F is (Xcover3velte). Did not manage to finad alternative TWRP for Xcover3. – klen Sep 19 '16 at 13:55
1

This is usually an issue with your root method NORMALLY means it is using an older bootloader than the minimum allowed (through OTA updates the minimum allowed bootloader version can change). When the phone goes to boot using the new loader in to recovery it is hanging. Once you restart the changes are reversed because the device is not fully rooted and the newly installed TWRP is being overwritten by the backup of the OEM recovery because it can tell there is some issue with the recoery (whether the install signature fails, the method they use to get root is patched, etc.). I would look around for an updated root method and be sure you follow it step by step.

This appears to be the newest set of instructions for your device: http://www.galaxyrom.com/2016/04/update-galaxy-xcover3-sm-g389f-g389fxxu1apc7-android-6-0-1.html

I would also if you can do a factory reset, and reinstall or install if it is not already to the current OEM ROM version mentioned on that page (linked there). This way you are sure you are rooting exactly what is expected by the rooting process.

So Update ROM if needed and then further down the page is root directions. Note they say to make sure auto reboot is checked as part of the instructions so this may be a requirement (a script or other software may be expecting it to do something).

  • Followed your suggestion but the rooting ends with same result. Flashed the stock rom, left auto reboot flag and F. reset time checked. The only thing that left is to flash with the exact stock ROM mentioned in the link (G389FXXU1APC7). I am currently flashing G389FXXU1APF2 which is listed as stock for my region. Will report on end result after download completes. – klen Sep 18 '16 at 11:47
  • Had difficulty downloading framework from above-mentioned link. This is good alternative [link] updato.com/…. You can choose any official firmware and get normal download speeds for free. – klen Sep 19 '16 at 7:41
  • Tried installing stock ROM mentioned in the link (G389FXXU1APC7). The end result is the same. – klen Sep 19 '16 at 13:49
1

TWRP for SM-G389F (Xcover3velte):

https://dl.twrp.me/xcover3velte/

And make sure "Auto-Reboot" is unticked in Odin.

http://forum.xda-developers.com/android/development/4-4-4-5-1-1-6-0-1-samsung-xcover3-t3465132

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.