1

I have a Nexus 6P and use it to connect to a Phantom 3 4K drone using WiFi. Obviously, because it's a private WiFi network with no external connectivity my phone can not contact the internet via WiFi.

This wouldn't be a problem but the app that I need to use, DroneDeploy, requires a connection to the drone via the DJI Go app (which needs to use the WiFi to connect) and the internet to pull down waypoint settings and to use mapping images.

I have a 4G connection however when my phone connects to the WiFi it doesn't seem to try and fall back on the GSM for external connectivity.

Is there a way I can get my phone to use the 4G connection for the internet connection while maintaining the private WiFi link to the drone?

Thanks in advance!

0

Android 5+ should do this automatically in most cases if there is no route to the internet you will see ! next to wifi icon in notification tray. You should also still see the mobile data icon showing you are connected to mobile data like LTE or 4G.

You could try to go in to developer settings and enable Cellular Data Always Active

Enabling Developer Settings Menu in Android 6 (4-7 I believe)

  • Go in to device settings
  • scroll to bottom
  • Tap About Phone or About Device or About Tablet
  • Scroll down to where it says Build Number
  • Tap this about 8-10x (You will see toast come up after the first several taps and it will say you are x taps away from enabling development settings).

When you are done you can hit back until you are back to the Device Settings window. Now you should see a new entry toward the bottom labeled Developer Options {}

Enabling Cellular Data Always Active [and possibly Aggressive Wi-Fi to Cellular Handover]

  • Go in to Device Settings Menu
  • Tap Developer Options
  • Scroll Down to Cellular Data Always Active
  • Tap to Enable this As it says it will keep Mobile Data connected even if Wi-Fi is connected (so when you disable Wi-Fi Mobile Data is already there no wait. This can cause your battery to drain more quickly (mine isn't hardly noticeable and I have this enabled and have for some time), but if battery life is a concern it is something to keep an eye on until you have used it and know how your device reacts.
  • You could also try enabling Aggressive Wi-Fi to Cellular Handover at the same time as this tells the device to favor cellular data when Wi-Fi Signal is low, BUT if drone signal gets low while flying Wi-Fi may drop in favor of Cellular so you may want to try this when drone is flying in safe conditions. This is just something that could help you in your endeavor it is not a mandatory setting if you rather leave it disabled and only try it if you don't get what you want in your first tests.

Caveat with some Basic Info

You MAY still have some issues since you will now be connected to both networks. You won't know without testing if for instance I go to a website it first sends out a DNS request. The device will have to choose whether to use Wi-Fi or Cellular Data for this request which is hard to adjust [Google: Split DNS VPN to get a feel for what I mean here]. You can get all nitty gritty and look at modifying the routing table if you have root access and all, but hopefully it just works and enabling this setting is all you need.

Note About Accessing Dev Settings

Some Android Versions maybe slightly different in ow you "unhide" developer settings. So, if what I detailed does not work you can Google: Android x.x Enable Developer Settings (replace X.X with your android version ie. Android 4 or Android 4.4.1 depending on what exact version you are running).

  • I enabled data always active mode and tried again. When I first connect to the private WiFi network, I see that the WiFi Indicator has the !, and next to it is the cellular signal strength with 4G above indicating that i have a data connection. The drone fails to connect until the nexus pops up with the "This network has no internet connection, do you want to stay connected" box. If I say "Yes" then the drone connects, but the 4G indicator is removed and I lose internet connection. If I ignore the box, I retain internet access from the 4G but am unable to connect to the drone. :/ – Chaostime Sep 14 '16 at 15:21
  • 1
    @Chaostime yup. Android still doesn't support having two active connection completely. You can actively communicate over just one. Samsung Galaxy S6 and above and some other OEMs' phones have ability to connect to two networks and communicate over them actively under certain circumstances. You might want to look into that. Stock/Vanilla android OS can itself communicate with two networks but allow apps to only use one of them (the active one). But on certain custom ROMs and OEM devices, you can connect to resources from both devices. your Drone is on WiFi and internet is via 4G, causing issues – Roh_mish Sep 19 '16 at 5:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.