0

I was able to install android x86 on my laptop with a 20GB partition and configure the system according to my tastes yesterday. Also yesterday, I tried using this app to uninstall some bloatware on my system, such as:

  1. Browser
  2. Calculator
  3. Gmail
  4. Keyboard
  5. Youtube
  6. Velvet (I think this is the google app)

I tried getting rid of this stuff since it's all either unimportant or I have better apps instead, such as opera, hacker's keyboard, and deepstack calculator. When I tried, google's services started dying, and then larger apps like atom launcher started dying. Now, whenever I try to boot into android, it's stuck at the loading screen, though I do have access to a root terminal. Luckily, I still have the '.apk' files available as well as the configuration files. I tried to fix this by using 'pm install', and, even though it starts to install the package, it isn't able to. When I try to pass other arguments to 'pm', it just says that the service isn't available.

Now, I don't want to have to go through a re-install and configure android again, so how do I either: 1. Start the service so that it works 2. Manually re-install the packages?

The device is still bootable to some other OSes. All help is appreciated.

EDIT: I did not delete any services, only these apps that I have uninstalled from a separate tablet of mine and know to be unimportant.

  • Bloatware is crap the OEM loads on, like how Samsung cram Dropbox onto the OS. What you have been removing (other than YouTube) is actually quite essential. The answer below is spot on - if you things like opera need internet access, which tends to be managed by the stock browser. – Dan Brown Sep 19 '16 at 7:33
  • Damn. I did just re-install a while ago. – Mr. Minty Fresh Sep 27 '16 at 16:21
  • It working now? – Dan Brown Sep 27 '16 at 16:36
1

As someone who develops apps (okay, not very sophisticated ones, but still) I know that many 'improved' versions of things rely on the originals being present. If you delete the originals the new ones don't work. As a simple example, an all bells and whistles photo editing program may rely on the basic camera 'service'. If you delete that service, it doesn't work. In your case, I would guess your hacker's keyboard relies on the basic keyboard.

As a general rule: unless I am certain it can't affect anything on the phone or I downloaded it, I don't delete it.

I would just start again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.