Samsung Galaxy Tab 2, GT-P5110 Android version: 4.2.2.

Hi there, I have a rooted device running on CyanogenMod 10.1.3-p5110, with a custom recovery CWM After 3 years (or so) of smooth operation it started to slow down and getting unstable from time to time, so I decided to factory reset. I did the factory reset from CWM following the regular regular instructions, however after reset completion the devices booted back to the original CM10, with all the original data (nothing was cleaned at all or reset). I tried several times from - cleaning cache, date, system, dalvik cache, factory reset ... still the same result.

I also tried to replace the CWM with TWRP (GT-P5110_TWRP_3.0.0-0.tar.md5) - same result, it shows success but if I restart to recovery, it goes to CWM

If I boot into recovery (CWM) and flash any rom, it shows success and then reboots (guess what) into the original CM 10 like nothing happened. I tried to flash the stock firmware using Odin. I got an original firmware "P5110XXDMI1_P5110OXXDMJ1_HOME.tar.md5" from a reliable source (http://www.sammobile.com/)

Model:GT-P5110, Model name:GT-P5110, Country:Czech Republic, Version:Android 4.2.2, Changelist:1709803, Build date:Wed, 18 Sep 2013 06:13:11 +0000, Security Patch Level: N/A, Product code:XEZ, PDA: P5110XXDMI1, CSC:P5110OXXDMJ1

Every time I flash the original stock rom with Odin, the ID:COM box in Odin goes green and everything looks just fine but after reboot the tablet restarts to the original CM10. I was using Odin3-v1.85, as well as newer versions of the tool - namely Odin3_v3.07, Odin3_v3.11.1, all with the same result.

I even tried form very scratch - repartitioning the device using a .pit file "signed_espresso_20120220_16G.pit", flashing stock using Odin, same result. I also tried flashing rom Heimdall Suite - same result

I have no problem to connect to the device using ADB shell and communicate with the device ... to get the partitions details using these instructions How can I view the Android internal partition table? However, I am not any Android guru, so I cannot "decode" what I get.

To me it seems like I somehow messed up my partitions or mounts and thats the reason for the strange behaviour. So now I am stuck in strange state, which I cannot call a bootloop ... seems like I am running some sort of cached system or someting and I am unable to get out of with any standard tool available. As I said ... device is rooted, running CWM and I can boot to any mode I want ... download, recovery, system.

Any help will be more than appreciated.

  • Jeez, quite a pickle. Considering the age of the device, it is possible A faulty eMMC is to blame. Switching from CWM to TWRP is a mess too. Sighs If you can use TWRP manager to flash TWRP (play store, thank God!) And if it works, use ADVANCED WIPE. It should ask you to type yes in a box. Also, moral of the story: Use TWRP. it's a lot less hassle.
    – Dan Brown
    Commented Sep 19, 2016 at 0:16


You must log in to answer this question.

Browse other questions tagged .