2

Whenever I try and adb pull an installed APK from my device, it says adb: error: remote object {name} does not exist. I've tried and it works with files in /sdcard, and I definitely have access to the APK. I can also ls inside the app's install directory and it will be fine.

Here is an example with Snapchat:

pm path com.snapchat.android gives me /data/app/com.snapchat.android-2/base.apk

ls -l /data/app/com.snapchat.android-2gives me

total 153872
-rw-r--r-- 1 system system  78767561 2016-09-02 13:03 base.apk
drwxr-xr-x 3 system system      4096 2016-09-02 13:04 lib
drwxrwx--x 3 system install     4096 2016-09-02 13:05 oat

I can stat and cat the base.apk, which proves there isn't a file permissions issue.

I've restarted my phone, restarted adb, rebooted my computer, tried it with other apps, tried it with everything and nope, it's like adb just can't see it. Anything I can try or do?

Update

  1. Forgot to mention I am using adb on Windows 7. When I use cmd.exe, the above happens, but when I use git bash (on MinGW) it gives a weird error: adb: error: remote object 'C:/Program Files/Git/data/app/{apkName}/base.apk' does not exist.

  2. I ended up pulling the APK through one of those WiFi file transfer apps which present a UI over a HTTP server. Based on #1, it must be a weird bug on my system/with adb where it won't properly parse a path.

0

Okay, the way I did it was this.

Shell into the directory and then use Linux cp to place it into another location. for me I used /sdcard/downloads

I was then able to pull the file from that location / access it from within my phone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.