0

I have an LG G3 which does not have recovery mode or download mode. The only available mode at the moment is the fastboot mode.

I installed the the fastboot tool using the "minimal fastboot and adb tool": http://forum.xda-developers.com/showthread.php?t=2317790

And tried executing many fastboot commands as follows:

fastboot erase aboot
fastboot flash aboot aboot.img 
fastboot erase boot
fastboot flash boot boot.img
fastboot erase laf
fastboot flash laf laf.img
fastboot erase rpm
fastboot flash rpm rpm.img
fastboot erase recovery
fastboot flash recovery recovery.img
fastboot erase modem
fastboot flash modem modem.img
fastboot erase misc
fastboot flash misc misc.img
fastboot erase sbl1
fastboot flash sbl1 sbl1.img
fastboot erase tz
fastboot flash tz tz.img
fastboot erase dbi
fastboot flash dbi dbi.img
fastboot reboot

However none of the commands executes successfully, I always receive:

FAILED (remote: failed to erase partition)

What could be the reason for fastboot failing that way? Could it be that there is no partition on the phone at all? Or does the bootloader need to be unlocked for this to work in the first place? Maybe the driver is not correct, but on the other hand I see the commands showing up on the screen of the device -- so it receives them.

  • Correct me if I'm wrong, but LG devices don't have a conventional fastboot, the bootloader is locked by default and not unlockable (methods like Bump only overrides it). If you've previously enabled fastboot (and in turn disabled download mode) through the dd trick then you might need to resort to QCOM 9008 mode. – Andy Yan Sep 28 '16 at 1:48
1

I will provide an answer covering all the steps that I had to go through in order to get that LG G3 working again.


Being stuck in fastboot mode

When that phone was given to me, the person owning it before had tried to flash some custom rom. After failing miserably the phone was stuck in fastboot mode.

Trying to get the phone out of the fastboot mode, I tried the following guides:

Fixing the phone with the fastboot did not work for me.

Since I had nothing to use I decided to try the "Qualcomm unbrick" method


Qualcomm Unbrick:

  1. There are 3 useful posts on how to get into the Qualcomm mode and how to unbrick the device: i) the reddit post ii) the open-freax post iii) the xda post
  2. Start by following the reddit post
  3. The tools to use: i) Qualcomm drivers: the drivers in the reddit link are legit ii) willcracker's tools: There are different versions of willcracker's tools (aka the BoardDiag tool). I used version 2.99a.

Edit: Here another post providing photos for getting into Qualcomm mode


Troubleshooting

If you follow carefully the reddit post (and if you are a bit lucky), you might get through this process without a problem. However I had 2 issues

  1. "device not found in dload trying flash programmer" -- I got this message when running the initial step of BoardDiag. Turns out, this problem occurs if you release the shorting of the pins a bit too early:

here l33tlinuxh4x0rsays:

  1. once you have extracted the firmware and set up the program with the correct port you need to Check "AP" and "EMMC" then press start. Be sure not to select any partitions or change any other options than the firmware directory and comport. It should come back as PASS. If it throws an error about not being in dload mode you need to restart the shorting process. Hold the short for a bit longer this time.
  1. FAIL on the EMMC test -- If you manage to get through the AP Chech test, and receive FAIL for the EMMC the solution is provided in the open-freax post:

If you’re lucky enough (again) both of the tests will be OK. If, like me, you have nothing but a huge FAIL on the EMMC test, in the options list switch « Read/Write » to « Erase », unplug/plug your G3 (always with your metal wire to have 9008 mode, that’s pain in the a*s but it’s mandatory) and click START again. Internal memory will be entirely erased. Do a « read/Write » again, this time it should be a PASS

For the remaining of the steps regarding the BoardDiag tool I suggest you follow open-freax post.


Installing back the stock ROM

I was unlucky with the ROM and managed to install one with malware on it. So you might want to invest some time to find the correct rom for your device.

There are two methods (or maybe more) for flashing rom to you LG G3.

  1. TOT + dll method: for this method follow this post from the section 2015 (updated with pictures) TOT Method, also this post is useful
  2. KDZ: for this method follow this post again, starting from How to flash ROM KDZ Method

To find proper roms you might try the following pages:


Other method for the Qualcomm unbrick

There is also another method for unbricking Qualcomm devices, but I did not have to use that one.

references: http://www.leakite.com/2016/06/revised-how-to-unbrick-qualcomm-android.html http://www.droidsavvy.com/unbrick-qualcomm-mobiles/

  • Yes this is what I'm talking about. +1 for digging into it and writing a detailed answer. – Andy Yan Oct 4 '16 at 0:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.