I just got a Galaxy Nexus and all is good apart from that my Sync Browser doesn't work. When I run logcat against it it gives me the error of :

BookmarksSync  I  Sync failed due to soft error: Skipping any commits.

I've seen some pages online which describe this issue and suggest fixing by removing all your bookmarks and starting again, but I'd rather not do this. *see edit below

Does anyone know how I can fix this without removing all my existing browser setup? or if this is the only way, can someone point me to a page with clear instructions.

** EDIT ** I tried removing all my bookmarks and syncing and it's still giving me an error with no bookmarks present.

  1. Disable syncing in Google Chrome.

  2. Remove stored sync data on your Google Dashboard.

  3. Enable sync again in Google Chrome making sure that only the passwords are encrypted.

  4. Disable and enable sync browser in ICS.

There is a more detailed howto with photos on my blog if you need it.

| improve this answer | |
  • Yup from the comments on the Android issue tracker it seems that encrypting everything is the issue here - in order to have browser sync, you need to have unencrypted data in chrome sync. – Martyn Dec 19 '11 at 10:14

I had a similar issue.

Eventually, I disabled the following:

auto fill forms; sync via USB an developer tools. It worked!

Oh also I cleared data (settings..content settings) for Google sites.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.