1

I am running Cyanogenmod on my Galaxy S2 for about a year.

A few months ago I bought a new phone and game my Galaxy S2 to my mom to use as a second phone. I did a Factory Reset before that. Everything was working fine, including root.

Recently I took the phone back and did a Factory Reset again, but now I lost root access. It is set to "Apps and ADB" in developer options btw.

I tried reinstalling Cyanogenmod, no luck. Tried flashing recovery (I am using clockworkmod and it worked file all the time), no luck.

EDIT

That's what happens when executing "su"

10
  • What happens when you "su" in a terminal emulator?
    – Andy Yan
    Sep 29, 2016 at 0:34
  • @AndyYan, I've updated my question.
    – geNia
    Sep 29, 2016 at 12:39
  • That looks as if you haven't enabled it (but you said you did). I'm at a loss.
    – Andy Yan
    Sep 29, 2016 at 13:24
  • @AndyYan, yes, me too. I tried flashing another ROM, based on Cyanogen. Same thing.
    – geNia
    Sep 29, 2016 at 15:13
  • 1
    @MikeN, it doesn't help.
    – geNia
    Sep 29, 2016 at 19:16

1 Answer 1

0

I tried flashing SuperSU .zip file and after a few attempts it worked. No idea what was the problem, but it is fixed now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .