I just recently updated to marshmallow on my Oneplus X, ever since I did that I've been getting notification that "Unfortunately, Google Play Services has stopped." I've done tons of research and tried many things like clearing the cache, force stopping it, uninstalling updates, rebooting my phone, messing with the wifi. Even after all of that it won't go away. The message is popping up every 2-3 seconds and is really making it hard for me to do anything. Is there anything else I can do or should I get help??


You do not need to 'disable' the entire Google+ app. Your Play Services can stop working due to several other reasons.

First - Install the latest Google Play Services .apk file!

Second - If installing that doesn't fix, clear the Google Play Services cache. The Google Play Services app in your phone acts like a framework for all the Google and Google Play apps installed in your phone. You can try cleaning up its cache and see if that would fix the issue. This worked with one of our team members! Read these quick and easy steps :

  1. Go to Settings > Apps.
  2. Scroll to All apps and then scroll down to "Google Play Services" app.
  3. Open the app details and tap on the "Force stop" button.
  4. Then, tap on the "Clear cache" button.
  • Could you attach reference points and list causes of the problem. – user145490 Oct 5 '16 at 20:26
  • What if the "Force stop" button is disabled/greyed out? – MrWhite Jun 2 '17 at 22:46

I was facing this same issue. Its resolved now.

Just uninstall google + and reboot.

It will work.

  • 1
    Google+ is installed as a system app on some devices and can't be uninstalled without root. – user598527 Oct 5 '16 at 8:12
  • This isn't a viable option for those who use G+ and experience this problem. Wouldn't recommend it as an answer. – user145490 Oct 5 '16 at 20:25

Not the answer you're looking for? Browse other questions tagged or ask your own question.