4

Somehow my default keyboard got changed. I used to be able to go to Settings -> Language and Input and then there was something that would let me change the keyboard. Now under "Keyboard and input methods" I only see "Virtual keyboard" and "Physical Keyboard". When I select the former it lists all the keyboards I have installed and enabled, but doesn't show me which one is the selected keyboard. If I tap any of the keyboards it takes me to the settings for that keyboard, which doesn't provide me with any way to make that keyboard the default. Long pressing does the same thing. There is nothing helpful under the menus. If I tap on "Manage keyboards" it shows me all the keyboards installed, and a mini-slider showing if each is enabled or not and allowing me to change. But again, nothing to set the default!

How do I change the default keyboard in Android N?

Update: Apparently Google doesn't even know how to do this - I contacted chat support and the agent wasn't able to help me!

5

It appears that some keyboards offer something under their keyboards (e.g. a special key) to switch keyboards. However others, such as the Google Keyboard do not.

However, what I have discovered is that whenever the on-screen keyboard is up, no matter which keyboard it is, there is a new virtual button at the bottom right of the screen with the icon of a keyboard. When I tap this icon a dialog box pops up to change the keyboard.

screenshot

1

Whenever you can input text, a "Select keyboard" notification should appear:

Select keyboard notification select default keyboard
Select keyboard notification / default keyboard (click images for larger variants)

Clicking on that will bring you to a screen with all of your enabled keyboards for selection (second screenshot). Selecting one of these options will set it as the default keyboard anytime your keyboard appears.

0

I just figured out how to do the same thing on the Google keyboard while searching for the same thing. Hold down the little globe icon to the left of the Spacebar and it will list all available keyboards.

screenshot showing 'Change keyboard' options

Click to enlarge

0

TL,DR: try reinstalling your keyboard app

If you're like me and none of the three other solutions worked (keyboard button, globe button, or holding spacebar) Try uninstalling and reinstalling your keyboard app. With mine part of the first time set up included it bringing up the default keyboard selection. I can't get to settings disable it now but that doesn't really matter...

0

OK I had to go to my apps under Google play and click Gboard. Then I got a wizard that allowed me to set gbaord as default. Samsung default keyboard sucks. Gboard is better.

0

I had the same problem. I installed Gboard and it would then let me turn off Samsung Keyboard. After that, I was able to set the other keyboard I've used for a long time as the default

-1

Spacebar trick didn't work for me and there was no globe icon on my Samsung keyboard.

I searched for my keyboard of choice (G Board) in the Play Store, opened it and select it as my default from there.

  • 1
    Please explain what the "Spacebar trick" is. – Ethan Z Mar 20 '17 at 14:13
  • Some keyboards let you change languages by swiping the spacebar left or right. It might have the text [ < English> ]. This however is changing 1 keyboard's language rather than switching the keyboard itself. – Paul Totzke Mar 29 '17 at 18:45
-2

Press and hold spacebar. A pop up will appear after that where you can choose your default keyboard.

Not the answer you're looking for? Browse other questions tagged or ask your own question.