It seems like copying a file onto the SD card ought to be easy, but for the life of me I can't figure out how to do it. I have an (International) Motorola Xoom Wifi running stock Moto Android 3.2.

If I insert an SD card with content on it, I can see the contents of the card show up in the tablet's Gallery app. I can also go into the built-in Files app and browse the contents of the SD card. Using the Files app I can select files and copy them from the SD card to the internal storage.

However when I browse the tablet's internal storage with the Files app and select and Copy a file, if I then navigate to the SD card the Paste Here option is grayed out.

Using File Manager HD, I can't even find the SD card. It looks (from the Files app) like the SD card is at /mnt/external1/ but I can't see any way to get there. Is there something I'm missing in File Manager HD to find the SD card, or is there a deficiency in File Manager HD that another file manager could solve?

Also strangely I can delete files from the SD card using the gallery app, but not using the Files file manager app!

  • Which filesystem is on the SD card?
    – Flow
    Nov 21, 2011 at 23:02
  • @flow (unlike earlier today) I'm now home with a proper laptop available which says the card is FAT32
    – GAThrawn
    Nov 21, 2011 at 23:21

2 Answers 2


Getting to your external in File Manager HD is...not very obvious. The only way I'm aware of to get to it is to hit the Home button at the top right on the action bar (not the Android OS button in the bottom left) and then hit Up. This should put you at /mnt, so you can get to the external at /mnt/external1. The "Storage" shortcut on the left pane also takes me there, but I don't think it's always operated like that in the past. I might be mis-remembering there, though. If "Storage" takes you to /mnt/sdcard then you can hit "Up" from there to get back to /mnt.

As for copying, the external card was originally read-only by default. Now it seems to exist in some kind of weird limbo (at least for me) and I'm not entirely sure how the permissions are designed. File Manager HD shows its permissions as dr- (that is, read-only directory) but it lets me paste files there anyway. Nonetheless, if you're rooted you can use something like MicroSD Mounter as an easy way to remount it RW (it works fine for me).

I should probably also note that the above is on Android 3.2.2, after getting Verizon's LTE upgrade. The permissions may still be read-only for Xooms in other regions, but I'm not sure. Mine could also just be read/write because I'm using a custom kernel and boot image (don't remember if it was in there).

  • Wow never would've thought to press Up when I'm already at what looks like the top level. So now I can browse to /mnt/external1 but FMHD won't let me edit anything either?
    – GAThrawn
    Nov 21, 2011 at 22:20
  • @GAThrawn: Yeah, it's probably still mounting read-only by default. I don't think you can modify the contents of the external card via your Xoom without rooting and remounting it read/write. I have no idea why Moto designed it that way. Nov 21, 2011 at 22:30
  • @elder Well that's annoying, and is a point against this as a laptop replacement. I know ICS has further changes to the way internal/external storage work, wonder if it makes SD card file management a bit saner for cases like this where I just want to sort photos on the card?
    – GAThrawn
    Nov 21, 2011 at 23:26

Well that's strange timing!

Just received an update notification on the tablet, installed the update and suddenly I can copy files to the SD card, delete files from the SD Card and create folders on the SD Card with no problem! This was using the built-in Files app.

It's still saying my Android Version is 3.2, but the build number has updated to H.6.6-23, so can only assume this is an update to the drivers or Motorola's software rather than the OS itself.

Found a thread on the Xoom Owner's forum mentioning it Another UK update?

I just received another update to my UK wi-fi xoom. I already had the original 3.2 update.

I didn't really catch the update number, but the release notes appeared looked to be the same as the previous big update.

It was very small (only 1 or 2 k!).

I could only really think of one reason this might have been sent out, so tried copying from the internal memory to /mnt/external1 (a 32 Gb sd card) and it worked!

So it looks like this was probably a fault that they've pushed out a fix for, rather than any design problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .