0

I have installed Swiftkey in my system. However, search does not show it. Going to play store, I see it is installed, and only there, I can open it.

Fig. 1 Search successful, Fig. 2 Swiftkey visible in Play Store, Fig. 3 Open button for Swiftkey, Fig. 4 Frontend of Swiftkey, Fig. 5 State of application after disabling and force quitting it, Fig. 6 State of application after disabling, force quitting and "uninstalling" it

enter image description here enter image description here enter image description here enter image description here enter image description here enter image description here

It started to persist in OO 3.1. I created the ticket #712004 about the issue in Oneplus technical ticket system.

Uninstallation attempts

Unsuccessful uninstallation witohut disabling and/or force stopping application first.

  • I pressed uninstall the application. However, doing so, it is not really uninstalled. You see the situation in Fig. 3. Reboot the phone, and you still get the same result. You cannot uninstall it by dragging the icon to uninstall menu because no such icon exists.

Procedure for the partial uninstallation of the application i.e. deactivation, since there exists an evidence about its existence in Fig. 5 in the system

  1. Press the Menu key and choose Settings → Apps → Manage applications OR tap 'Apps' (depending on device)
  2. Scroll down to and tap SwiftKey
  3. Force stop application
  4. Disable application
  5. Select 'Uninstall' in Play store now; OR uninstallation process will automatically start if you selected it before force stop and/or disable
  6. Reboot

Output: the application is not active but we can see the application is still in the system register in Fig. 6 although we diasbled, force quitted and "uninstalled" it in Fig. 5.

Phone: Oneplus two
OS: OxygonOS 3.1

0

Official Oneplus answer about the topic

  1. Revert OS back to 3.0 over remote session

    Since this issue have occurred after an update then I would like to suggest that you undergo a remote session. This could be a compatibility issue thus I suggest that you revert back to the previous OS version where you are having no issues at all.

This choice is one viable solution because the normal uninstallation of the application does not work. However, I did not agree with them and required for more steps about uninstalling the specific application and studying the system why the condition exists.

I also gave 1 star rating for SwiftKey to signal the current problem. I will remove it as soon as possible the problem is understood and fixed in both sides.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.