0

I have one google account for my android phone. Now I set up a work email at gmail to use the shared calendar and keep things separated. For convenience I downloaded the google calendar app to display events from the calendar on my phone. I followed the steps to add another google account to my phone via Settings -> Accounts -> Add Account -> Google. Everything worked out fine, but on the google calender no events are shown. When I go to Settings -> Accounts -> Google -> workaccount I can't see the toggle for Calendar syncing. In the phone account I see this though.

With the same account I added the calendar to thunderbird using lightning and followed the procedure which worked out fine. Therefore I assume that the accounts calendar is visible.

My phone is a Oneplus One running CM 12.1 (Android 5.11)

0

So the solution for me was:

First activating Device Information in my Google Activity Settings.

Second I deleted the account from the phone and added it again. There was the toggle for syncing the calender.

Third I needed to allow google calendar to have access to the calendar storage, which was prohibited by default from the Privacy Guard in CM. This solved the sync error problem.

Now all my calendars and events show up on my phone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.