So this is kind of a two fold question but it all falls under the same umbrella of update status reliability and might even be caused by the same factor.

First, this morning I saw that my Logitech Revue remote App had an update, as indicated by the 'Update' label when viewing list of apps. However when I clicked it, the only options were 'Open' and 'Uninstall'

I attempted to clear Market's cache and force close it, but still the same thing. 4 Hours later. it worked normally (i.e., providing the update button).

What causes this and how can I fix it immediately, rather than just checking back every few hours to see if it was fixed.

Second part/example: A couple weeks ago the same issue happened with the system app 'Youtube.' Under my main google app that I use on my phone and all my non-system apps are associated to, I saw the update label, but again same issue as above. When I switched to my other account that I only use for email, I could update Youtube just fine.

There seems to be some sort of synchronization problem. The Youtube example lasted for days (with the daily update notifications) before I thought to switch accounts and try it on my secondary google account. The exact same thing happened with Google Maps.

I have a stock Droid 3 using stock Market.

  • 3
    I've experienced both issues myself. I think the app updates are being rolled out in batches as to not overload Google's servers, while notifications go out immediately. I don't know for sure that this is the cause, just pure speculation on my part
    – Chahk
    Nov 22, 2011 at 20:12
  • I've never experienced this myself, but I do think Google has some sync problems with the Market. When I push an update for my app, I can generally open the Market on my phone in ~10min and will see the update. But it can take hours for the info (new description, version number etc) to appear
    – pyko
    Nov 23, 2011 at 0:13
  • This no longer seem to happen? Market ver 3.4..
    – Irfan
    Dec 29, 2011 at 13:22
  • @Power-Inside not that I've noticed. knocks on wood Jan 4, 2012 at 18:13
  • @Power-Inside Go figure, yesterday this issue did occur with Tasker, but resolved itself when I checked my app list again about 12 hours later. Jan 9, 2012 at 4:24

1 Answer 1


I have noticed that I sometimes get a notification that an update is available, but when I go in there, I am unable to update. I, at first, thought that it was some type of syncing issue like you describe, but I have realized ( at least in my situation ) that I have the apps set to update automatically. So I get the notification, but the market actually has already updated the application in the background.

Based on your comments, and if you eventually go in to the market and there is actually an update available for an app that you previously were notified about, then I would say it has to do with how google rolls out the updates. As Chahk discussed, the notifications seem to go before the apps, in some cases. Google does this with just about everything they roll out. Updated in batches.

  • I specifically turn off all the auto-updates on those apps. I generally don't like it when things change without me telling them to, just as a matter of preference. Jan 24, 2012 at 20:07
  • I have updated my answer. Jan 24, 2012 at 20:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .