I've bought a Pioneer radio for my car that supports Android Open Acessory (AOA) 2.0. I was happily living with it playing my music through the USB cable to my Galaxy S5 phone. High quality connection and charging at the same time. Just one cable. It was great.

To configure it, it was just necessary to select the correct USB connection type (MTP, if I remember well).

Now here comes an update to Android 6.0 and everything stopped working. It still charges, but I can't make the music go through the car speakers. The USB options now are inside the developer mode. I've tried all the options, but can't make the music go through the USB cable.

My old Moto G, with Android 5.1, successfully connects and plays through the USB cable.

Any fix, workaround, or help to debug is appreciated.

1 Answer 1


The problem is that I was using an app called SoundAbout that automatically routes the audio output. I've installed the app to use in a car that I rented and forgot about it. It is a nice app, but gives no notification that it is in use. Just had to uninstall it and everything worked fine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .