I have an HTC Touch with Froyo installed that I use for app development. I haven't used it for a couple of months, and when I fired it up today I'm seeing the same error every time I launch the Market app: No connection and a Retry button. It doesn't matter how many times I hit Retry, I just end up back in the same place. The phone definitely has a solid Wi-Fi connection though and all other online apps (browser, Twitter, etc.) are working well.

I've tried force stopping the Market and restarting, clearing its data and uninstalling updates, all to no avail. What can be causing this error?

5 Answers 5


The answer is that the date/time settings were incorrect. The device had been off for so long that the clock had reset. Once I set the correct date and time the Market app ran normally.

  • 2
    Found the answer in an Amazon forum after a lot of searching. Just thought I'd contribute it here too. :)
    – Mark
    Nov 23, 2011 at 10:46
  • 1
    I don't believe it!!!! time/ date worked! hahaha what an odd little fix! Android is a strange little thing
    – user11593
    Jan 14, 2012 at 1:00

I have had the same issure, but correct date / time. My solution has been to Turn Off/On the WIFI, works every time!


I had this problem once and it was because I was running DroidWall and I forgot to whitelist the Market app.


just clear your data and restart your phone

  • 2
    You might like to give more information on what data exactly you think Mark should clear, and how.
    – Dan Hulme
    Nov 10, 2013 at 19:16

Try clearing cache and data for the Market app. You can do this by going to menu>settings>applications>manage applications>all and scrolling down to the Market app then using the "clear data" and "clear cache" buttons.

  • Yep, did that as I said in the question: it didn't make any difference unfortunately.
    – Mark
    Dec 12, 2011 at 22:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .