I sync'd my PC-based Outlook contacts with my Sony Xperia XA, using MyPhoneExplorer. It tells me 3526 contacts are sync'd, and in checking the phone with ContactsOptimizer, it reports the same number. When I open the Contacts app, it does not show some of my contacts! I discovered this, because the first one I looked for was my own - not there!

However, when I called my phone from my house phone ... my contact entry came up! Picture and everything! And when I clicked "View Contact Entry", it showed me the whole thing - perfectly! But I go back into the Contacts app ... not there!

This happens for a relatively small (but significant!) number of contacts that I could see so far - in other words, not just one ... at least 10 I counted.

I tried Settings->Apps->Media Storage->Clear Data and reboot ... clears the picture data, for sure, but not Contacts!

PLEASE somebody help me get sane again! How can the contact be in the phone, but not show in Contacts?! I can't find any specific way to rebuild the Contacts app's database - only to CLEAR DATA, which I don't want.

PLEASE ... help me get sane again:-)

4 Answers 4


From the surface clues, I thought the index was corrupt. Not the issue at all. Being a newbie to the Android, I was unaware of all the myriad features of the beast:-)

A lot more digging found the "problem". Namely, I use lots of category designations in my Outlook contacts. MyPhoneExplorer does a 100% correct job of transporting all these ... BUT, turns out the Android contacts app in its FILTER option treats these in a bizarre way. Namely, if you try ...

Contacts->->Filter->Display contacts->Local

... you see that ALL the existing categories are checked ... BUT, the very bottom one ("All other contacts") is NOT CHECKED. The result is that all contacts WITH categories get displayed, and any without a designated CATEGORY are NOT displayed.

Simple solution (discovered after a week of hell:-)) ... just check the "All other contacts" box, and PRESTO! Now I see everything.

Post-script: whoever designed this "Display contacts" feature has it backwards! The default should be to show ALL contacts, with option to the user to narrow the selection by UNCHECKING various boxes.

  • I had the same issues on a newly acquired Nokia 3 running the Google contacts app on AndroidOne (plain vanilla android as Google intended just like the old nexus phones) and I confirm your solution is correct for the Google contacts app. Can't vouch for Samsung's addresbook, though.
    – hlecuanda
    Mar 31, 2018 at 1:20

There is a feature in Google Contacts that allows the user to display only a part of the contacts or all contacts. It is possible that you have yours set to customise.

In the Google Contacts app,

Go to Settings > Contacts to Display > Enable All contacts

I hope this fixed it!

  • Only wish it were so! My Contacts->Settings has only two options: Oct 10, 2016 at 8:55
  • (Sorry - didn't know I had 5 mins to edit after my <CR> inadvertently posted only the first line ... composed the reply in Word now! And see that formatting is thrown out - sorry again!) Only wish it were so! My Contacts->Settings has only two options: Accounts & Sync Service Dial Numbers There is no "Contacts to Display" option. Perhaps you're referring to a newer OS version? I'm on Android Marshmallow (v6.0), Kernel version 3.18.22+, July 1/2016. I'd post the screenshot, but it looks like this isn't supported here. Oct 10, 2016 at 9:05
  • I'm on Android 7.0 and Google Contacts 1.5.16. Are you sure you have installed the latest Google Contacts update?
    – usr
    Oct 12, 2016 at 10:14
  • See my own discovered answer:-) Oct 13, 2016 at 17:20

In my case I had to enable "Display contacts without Telephone number" and reboot my device.


Goto Contact ==> Settings ==> Contacts to Display ==> Enable all options ==> Restart your mobile. These options will be having to display contacts from SIM1, SIM2, gmail and etc. While displaying contact, do not forget to select All.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .